[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Emacs-diffs] Changes to emacs/lisp/simple.el,v [EMACS_22_BASE]

From: Glenn Morris
Subject: [Emacs-diffs] Changes to emacs/lisp/simple.el,v [EMACS_22_BASE]
Date: Thu, 01 Nov 2007 08:08:08 +0000

CVSROOT:        /sources/emacs
Module name:    emacs
Branch:         EMACS_22_BASE
Changes by:     Glenn Morris <gm>       07/11/01 08:08:08

Index: simple.el
RCS file: /sources/emacs/emacs/lisp/simple.el,v
retrieving revision 1.859.2.11
retrieving revision 1.859.2.12
diff -u -b -r1.859.2.11 -r1.859.2.12
--- simple.el   16 Oct 2007 02:05:55 -0000      1.859.2.11
+++ simple.el   1 Nov 2007 08:08:07 -0000       1.859.2.12
@@ -5647,7 +5647,14 @@
 You have loaded an older version of CUA-mode which does not work
 correctly with this version of Emacs.  You should remove the old
-version and use the one distributed with Emacs."))
+version and use the one distributed with Emacs.")
+    ;; vc-svn doesn't have a version variable (do we see the limitations
+    ;; of this approach now?), but the Emacs version uses `vc-svn-program',
+    ;; rather than `vc-svn-program-name', hence this hack should work.
+    (vc-svn-program-name t nil
+"`vc-svn' is now part of the standard GNU Emacs distribution.
+You have tried to load an older version which does not work as well with Emacs.
+You should remove the old version and use the one distributed with Emacs."))
   "Alist of packages known to cause problems in this version of Emacs.
 Each element has the form (PACKAGE SYMBOL REGEXP STRING).
 PACKAGE is either a regular expression to match file names, or a

reply via email to

[Prev in Thread] Current Thread [Next in Thread]