[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] Re: make error when making org fro git

From: Rainer Stengele
Subject: [Orgmode] Re: make error when making org fro git
Date: Sat, 12 Apr 2008 18:14:45 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv: Gecko/20080213 Thunderbird/ Mnenhy/

yes, that made it work.
I did not choose to use emacs 21 - it is debian 4 default version.

Actually I misused my debain system to try to get a "make" for my
windows xp where I cannot get anything to work natively from git.
Doing a "make autoloads" I try to use the lisp directory under windows.
Hope that will work.

With the old org "system" I could simply use the lisp files as given
but with the new structure I have to create the org-install.el file which is 
not working under windows.



Carsten Dominik schrieb:

On Apr 11, 2008, at 6:26 PM, Rainer Stengele wrote:

Hi all,

I want to make org-mode from git and get this error:

While compiling toplevel forms in file /u/tmp/org-mode/lisp/org-archive.el:
 !! Symbol's function definition is void ((declare))
make: *** [lisp/org-archive.elc] Error 1

It is the fault of emacs 21, I think.

try editing the file org-macs.el and delete all lines starting with '(declare',
then remove all .elc files with "make cleanelc", and try "make" again.

- Carsten

Emacs-orgmode mailing list
Remember: use `Reply All' to send replies to the list.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]