emacs-orgmode
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] Exporting with block agenda


From: Jan Seeger
Subject: [Orgmode] Exporting with block agenda
Date: Tue, 22 Jul 2008 19:49:59 +0200
User-agent: Wanderlust/2.15.5 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.8 (Shij┼Ź) APEL/10.7 Emacs/22.2 (x86_64-pc-linux-gnu) MULE/5.0 (SAKAKI)

Greetings,

I almost went crazy today trying to export my block agenda. I had my
agenda set up like this:

          (setq org-agenda-custom-commands '(
                                                                   ("c" "" 
                                                                        ((todo 
"NEXT|TODO") (agenda))
                                                                        
((org-agenda-with-colors nil)
                                                                         
(ps-font-size '(8 . 8))
                                                                         
(org-agenda-compact-blocks t)
                                                                         
(ps-landscape-mode t)
                                                                         
(ps-number-of-columns 2)
                                                                         )
                                                                        
("/tmp/todo-list.ps")
                                                                        )
                  ))
                  
, which seemed correct (show todos and an agenda together and export
it to the /tmp/todo-list.ps file. However, orgmode refused to export
the agenda. Looking at org-agenda.el, I edebugged
org-batch-store-agenda-views, and saw that in line 1774, block agendas
are (seemingly) not parsed correctly. With the syntax from the
documentation and! customize-variable, file and settings are the third
and fourth elements respectively.

So I inserted a nil between the commands and the settings, and my
block agenda miraculously exported.

Is the above setting wrong, or is that a bug in org-mode? (I'm using
6.04c with emacs 22.2-r2).

Regards,
Jan Seeger




reply via email to

[Prev in Thread] Current Thread [Next in Thread]