[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] Re: Problem with org-gnus-follow-link

From: Ulf Stegemann
Subject: [Orgmode] Re: Problem with org-gnus-follow-link
Date: Thu, 11 Dec 2008 17:18:06 +0100
User-agent: Gnus/5.13 (Gnus v5.13) XEmacs/21.4.21 (linux)

Hi Tassilo,

Tassilo Horn <address@hidden> wrote:

> Ulf Stegemann <address@hidden> writes:
>>> Please do a test for me:
>>> 1. Enter a group in Gnus
>>> 2. Delete the last article
>>> 3. Exit summary
>>> 4. Try `C-u 1 RET' on the group.  It should issue "No unread news".
>>> 5. Do `M-: (gnus-activate-group "<group-name>" t) RET'
>>> 6. Try `C-u 1 RET' on the group again.  Now it should be opened and
>>>    summary should contain one article.
>>> If you get different results it seems to be due to your gnus version.
>>> I use the one included in emacs 23 and update daily, so it might be
>>> more up to date than your copy.  Maybe try to update yours, too.
>> done that. I was under the wrong impression that the CVS on
>> cvs.gnus.org holds the latest version of Gnus but it seems it just has
>> the release from 1st May. It seems that latest Gnus is now available
>> from the Emacs CVS only (sorry for my ignorance).
> There's nothing to excuse.  I wasn't aware that the versions diverged
> that much, too.

yes, I really was surprised ... especially as gnus.org offers a 'nightly
snapshot' that also seems to be the version as of 1st May.

>> I installed that version here (5.13 as of today, see User-Agent
>> header)
> How?  Did you checkout GNU Emacs and copy all the gnus-related files
> somewhere?

Exactly, I got emacs sources by CVS and used the lisp/gnus/ files (plus
some other lisp files from gnus.org that where missing and XEmacs seems
to require). Byte-Compiling here with XEmacs 21.4 went smoothly, Gnus
runs as before ... at least until now ;)

>> but again the summary buffer is not opened.
> That's really strange.  BTW: What backend did you use for testing?  I
> used nnimap.  MAybe that makes the difference...

Gotcha! It works on nnimap but not on nnml which I was using for the
tests. Maybe you'll try this with your installation as well. If it fails
for nnml groups for you, too, that might be an important point for the
discussion you've started on emacs.gnus.general.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]