[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Problems with refiling

From: Carsten Dominik
Subject: Re: [Orgmode] Problems with refiling
Date: Thu, 19 Feb 2009 16:29:36 +0100

Hi Peter,

I am still having problems reproducing.

I did put your example into a file "peter.org"

* foooo
** refile me
** baz
* works
** one
*** two
**** three
* does not work
** a
*** b
**** c

Then I did these settings:

(setq org-refile-targets
      '((org-agenda-files :maxlevel . 3)
        (nil :maxlevel . 3)))

(setq org-outline-path-complete-in-steps t
      org-refile-use-outline-path 'file)

(setq org-completion-use-ido nil)

Then I followed your example: C-c C-w at "refile me".

Then I first need to type "peter TAB" to get the file name.
Then I do "does TAB".

I do get "peter.org/does not work/" in the echo area, a second TAB shows
"(complete but not unique)"

What am I missing?

- Carsten

On Feb 18, 2009, at 5:55 PM, Peter Westlake wrote:

This is now officially a bug report, with a reproducible test case!
Sorry there's no patch, but I'm at work and can't afford the time.

On Wed, 18 Feb 2009 15:57:10 +0100, "Carsten Dominik"
<address@hidden> said:

On Feb 18, 2009, at 12:17 PM, Peter Westlake wrote:

On Tue, 17 Feb 2009 22:32:28 +0100, "Carsten Dominik"
<address@hidden> said:
Hi Peter,

the whole purpose of completing in steps is that you see the level
2 headlines only after you have selected the level 1 headline.

Am I missing something here?

Yes: the level 2 headlines never appear. Instead, the entry is
refiled to the level 1, unless files are listed, in which case it
doesn't move at all. I must be missing out on some secret keystroke
to continue the step-by-step process, I guess.

Like pressing a few characters and pressing TAB?

No, I tried that a lot.

Maybe you are using the mouse to select top level headlines?  I never
use the mouse for completion, and this might well be the problem. When
you click with the mouse, you are telling the program that you are
done completing.

No, that works as you say.

Are you, by any change, using `org-completion-use-ido' as well? I
believe yesterday I forces off ido for the case of stepwise path
completion. There was a bug fix only yesterday, I think, about this.

No, I'm not.

I do have some new information to report, though! When your mail
arrived, I tried typing and TAB just to make absolutely sure my report
was correct. With use-outline-path set to Yes, step-by-step completion
worked perfectly! It still failed with use-outline-path set to include
the file. Feeling a bit stupid, I repeated the exact test where the bug
had appeared. And it still happened.

Some trees offered their subtrees on pressing TAB, and some said "Sole
completion", even if they had subtrees.

This happened with two trees in the same file, and with two subtrees in
the same tree. But in the end I found out what was happening.

Here's a test case that shows what makes the difference.

| * foooo
| ** refile me
| ** baz
| * works
| ** one
| *** two
| **** three
| * does not work
| ** a
| *** b
| **** c

On "refile me", C-c C-w.
Type "does", TAB, you get

  Refile to: does not work/[Sole completion]

Erase, type "work", TAB:

  Refile to: works/[Complete, but not unique]

Quit that, get rid of spaces in the "does not work" headline, and
completion offers you its subtrees. Add spaces in the "works" headline,
and you can no longer refile into its subtrees.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]