[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] reloading causes visibility bug requiring restart

From: Sebastian Rose
Subject: Re: [Orgmode] reloading causes visibility bug requiring restart
Date: Mon, 06 Apr 2009 14:05:02 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.91 (gnu/linux)

Cannot reproduce this on Linux/emacs23 with inline tasks on.

I added scheduling and logbock drawer too, toggled the todo state for
the inline tasks, reloaded again...

No problem at all.

Maybe a little test file would help to reproduce it?


Carsten Dominik <address@hidden> writes:
> I believe I know what s causing this.  Reloading Org actually
> does load *all* of org, including, for example,
> org-inlinetask.  I think that this is what is causing the problems.
> That will mean that org-reload needs fixing, and maybe that there is something
> wrong with the inline tasks.  If more people could test the  inline tasks, 
> maybe
> some bug will be identified.
> I don't use org-cycle-include-plain-lists, so it ma be that the interaction of
> inline tasks with plain list cycling causes some of the  problems.
> - Carsten
> On Apr 6, 2009, at 7:56 AM, Manish wrote:
>>> On Apr 5, 2009, at 8:18 PM, Samuel Wales wrote:
>>>> I can't do the typing to formally document this, so I will just ask if
>>>> others experience it. If not, it will take a while.
>>>> Repeatably, with the latest git, emacs 22 cocoa, reloading org causes
>>>> folding/visibility/cycling problems that are not fixable by reverting.
>>>> Only restarting emacs fixes it.
>>>> The problems are weird enough that it should be obvious if you try it.
>>>> Seemingly random plain list items being the only visible part, etc.
>>>> There is no cycling state in which all is shown, either from bob or
>>>> from headline.
>>  On Mon, Apr 6, 2009 at 12:57 AM, Carsten Dominik wrote:
>>> Hi Samuel,
>>> is this something that started recently, or that you have observed over a
>>> longer period of time?
>> I also experienced those cycling issues in past two days (with no change in
>> Org config, only git updates) but I have since Emacs a couple of times (for
>> unrelated reasons.)  I will try gather more details if I see it again.
>> --
>> Manish
> _______________________________________________
> Emacs-orgmode mailing list
> Remember: use `Reply All' to send replies to the list.
> address@hidden
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

reply via email to

[Prev in Thread] Current Thread [Next in Thread]