[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Re: DiTAA error under Ubuntu

From: Nick Dokos
Subject: Re: [Orgmode] Re: DiTAA error under Ubuntu
Date: Fri, 14 Aug 2009 06:59:09 -0400

Eric S Fraga <address@hidden> wrote:

> Is there any reason you do not wish to install either of openjdk or
> sun-java?  The gnu java implementation is (I believe -- I could be
> horridly out of date on this) still not complete, especially with
> respect to AWT.  My recommendation would be to install either
> openjdk-6 (which Nick I believe is using and works) or sun-java6
> (which I am using and works).

Seb is using openjdk. I, otoh, use Sun's version, as you do: perhaps
there is a problem with openjdk, perhaps it's just Seb's setup.

> Best is to do:
> update-alternatives --display java
> which will list the alternatives installed for that command as well as
> tell you the default.  For me:
> --8<---------------cut here---------------start------------->8---
> $ update-alternatives --display java
> java - manual mode
>  link currently points to /usr/lib/jvm/java-6-sun/jre/bin/java
> /usr/bin/gij-4.3 - priority 43
> /usr/bin/gij-wrapper-4.0 - priority 40
>  slave java.1.gz: /usr/share/man/man1/gij-wrapper-4.0.1.gz
> /usr/bin/gij-wrapper-4.1 - priority 41
> /usr/lib/jvm/java-6-sun/jre/bin/java - priority 63
>  slave java.1.gz: /usr/lib/jvm/java-6-sun/jre/man/man1/java.1.gz
> /usr/lib/jvm/java-gcj/jre/bin/java - priority 1043
>  slave java.1.gz: /usr/lib/jvm/java-gcj/man/man1/java.1.gz
> Current `best' version is /usr/lib/jvm/java-gcj/jre/bin/java.
> $
> --8<---------------cut here---------------end--------------->8---
> so my default Java is the one from Sun, version 6.

In my case, this gives

$ update-alternatives --display java
java - status is auto.
 link currently points to /usr/lib/jvm/java-6-sun/jre/bin/java
/usr/lib/jvm/java-6-sun/jre/bin/java - priority 63
 slave java.1.gz: /usr/lib/jvm/java-6-sun/jre/man/man1/java.1.gz
Current `best' version is /usr/lib/jvm/java-6-sun/jre/bin/java.

> > What do you advise me to do?  Installing another well-chosen
> > package?
> Yes, my recommendation would indeed be to install one of openjdk or
> sun-java.

I guess the question is: is there anybody with an openjdk install
for whom ditaa is working?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]