[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] [PATCH 0/2] Teach org-version to include git version info

From: Manish
Subject: Re: [Orgmode] [PATCH 0/2] Teach org-version to include git version information
Date: Wed, 19 Aug 2009 17:49:02 +0530

On Wed, Aug 19, 2009 at 5:38 PM, Bernt Hansen<address@hidden> wrote:
> Manish <address@hidden> writes:
>> On Wed, Aug 19, 2009 at 4:54 PM, Bernt Hansen wrote:
>>> Does it crash and cause an error or report the old org version as before?
>> It just reports the version as before; no crashing or error of any sort.
> Okay that's good. I don't have Emacs on windows here. If you have time
> to step through the org-version function in debug and figure out where
> it fails we might be able to get it working on windows too.

I'll find out how to do this and let you know the results.

> My guess is that determining the location of the .git directory fails so
> it acts just like it's not running from a git repository.
> What do you get when evaluating the following form?
> (file-name-directory (locate-library "org"))
> I need to move up one directory from what that returns to see if the
> .git directory exists and I append '../' to the path to move up on *nix
> systems. That probably doesn't work for windows. Maybe there's a
> better way to strip off the last directory from the path that
> file-name-directory returns.

It returns "d:/home/zms/elisp/org-mode.git/lisp/" cd'ing into
"d:/home/zms/elisp/org-mode.git/lisp/.." works in Cygwin but fails in
Windows shell due to front slahes.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]