[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Autoloading failed to define function org-mode

From: Ian Barton
Subject: Re: [Orgmode] Autoloading failed to define function org-mode
Date: Sat, 19 Sep 2009 08:04:41 +0100
User-agent: Thunderbird (X11/20090817)

Tamas K Papp wrote:
Hi, I have just switched to Ubuntu from Debian (fresh install on a new
machine).  After I installed the relevant packages (emacs-snapshot,
org-mode) and tried to edit my todo file, I got the error message

Autoloading failed to define function org-mode

I thought I would debug this a bit more before sending a bug report to

(require 'org-install) does not help (it is done in
/etc/emacs/site-start.d/50org-mode.el anyway).

Any hints/suggestions on how to proceed would be appreciated.

emacs-snapshot  1:20090320-1ubuntu1
org-mode 6.27a-1

I would suggest using the git version of org. I know this doesn't address the problem directly, but it's a good workaround:)

I put all my org mode stuff in a .emacs-lisp folder in my home directory. In my .emacs I have:

(add-to-list 'load-path "~/.emacs-lisp/org")

In my org makefile I have:

# Where local software is found

# Where local lisp files go.
lispdir = $(prefix)/org

# Where info files go.
infodir = $(prefix)/share/info

There is a tutorial in Worg on how to set up git to keep your Makefile customizations between different versions of org. Of course I can't find the link to it at the moment, when I need it:)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]