[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Beamer support - 2nd round

From: JBash
Subject: Re: [Orgmode] Beamer support - 2nd round
Date: Mon, 7 Dec 2009 15:15:49 -0500

On Sat, Dec 5, 2009 at 3:05 AM, Carsten Dominik <address@hidden> wrote:

On Dec 5, 2009, at 1:04 AM, Daniel Martins wrote:

Thank you very much

I did everything you suggested and everything worked nicely

But even using load-libray




I received

Loading /home/daniel/emacs-lisp/org-mode/lisp/org-beamer.el (source)...done
Loading /home/daniel/emacs-lisp/org-mode/lisp/org-latex.el (source)...done
Select command:
Exporting to LaTeX...
or: No definition for class `beamer' in `org-export-latex-classes'

If you have customized org-export-latex-classes before, then the value you stored will overwrite the new default (which contains the beamer entry.  Two ways to fix this:

1. Remove you customization of this variable, restart Emacs, and customize again to redo the changed you have made earlier.  THis is the safest way.


2. Customize the variable and create a new entry for beamer, with this:

So in your customize buffer it must look like this:

Note in paricular that under |levels|, you must choose "Hook computing section levels" from the value menu

- Carsten

2009/12/4 Nick Dokos <address@hidden>:
Daniel Martins <address@hidden> wrote:

Stupid question 9but I could not answer it)

I have to set up

(add-to-list 'org-export-latex-classes



Or I have to imput another .el which sets org-export-latex-classes correctl=

I sue the latest git version of org-mode 6.33trans and
I tried to use the example but I couldn't

Are you using git to keep up to date with org-mode? If not, then afaict,
you cannot get it yet. If you are using git, you can do something like this:

$ git branch -r

you can see there is a remote branch called origin/beamer. You can create
a local tracking branch with

$ git branch beamer origin/beamer

and check it out:

$ git checkout beamer

If you then look in lisp/org-latex.el, you should see the beamer stuff.


- Carsten

This is not working quite right for me...
I pulled the latest beamer branch from git this morning and installed it.  I am getting the export to latex, but no columns in the beamer (tex) and resulting pdf file.  There is a title frame, a TOC (blank) frame, and then a single frame titled "This is the first structural section".  All other elements are nested itemized lists on that single slide. 
I manually copied the org-beamer.el file to my site-lisp area.  Is that supposed to be installed along with the other org files?

I had also previously defined org-latex-export-classes, and have removed that from my .emacs file.
I am also seeing an unexpected error the *second* (and subsequent) time I export (without changes to the org file) to to PDFabout a column-width function:

Select command:
Exporting to PDF...
Exporting to LaTeX...
org-beamer-open-column: Symbol's function definition is void: org-beamer-add-units-to-column-width

If I restart emacs, I can export again (1 time) without these errors.

If this points to something obvious in my configuration, please let me know.  I suspect I have something strangely configured, as no one else is having these issues.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]