[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] [org-plot] org-plot dosesn't catch options from #+PLOT: line i

From: Holst Thomas (DGS-EC/EHM2)
Subject: [Orgmode] [org-plot] org-plot dosesn't catch options from #+PLOT: line if line does not start at column 0
Date: Mon, 1 Mar 2010 10:12:23 +0100


today I found out, that org-plot recocnises #+PLOT: lines only when they start 
at column 0. Most of my tables are indented. So org-plot didn't catch the 
options. Below is a patch which fixes this. The patch is against org-mode 
6.34trans from this morning.

I would like to take the oportunity to thank Carsten for marvelous org-mode and 
Eric for org-plot. They both make working with my computers a lot easier!!
Org-mode really changed the way I organize my work.

---%x-------------------- cut here ------------------------x%---------------
--- org-plot.el 2010-03-01 02:00:15.000000000 +0100
+++ c:/daten/users/DE_hts2fe/emacs/OrgMode/org-mode-aktuell/lisp/org-plot.el    
2010-03-01 10:02:33.934355700 +0100
@@ -301,7 +301,7 @@
        (setf table (delq 'hline (cdr table)))) ;; clean non-data from table
       ;; collect options
       (save-excursion (while (and (equal 0 (forward-line -1))
-                                 (looking-at "#\\+"))
+                                 (looking-at "[[:space:]].#\\+"))
                        (setf params (org-plot/collect-options params))))
       ;; dump table to datafile (very different for grid)
       (case (plist-get params :plot-type)
---%x-------------------- cut here ------------------------x%---------------

Mit freundlichen Grüßen / Best regards


reply via email to

[Prev in Thread] Current Thread [Next in Thread]