[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] Re: Support (or not) for Emacs 21, and XEmacs

From: Carsten Dominik
Subject: [Orgmode] Re: Support (or not) for Emacs 21, and XEmacs
Date: Fri, 16 Apr 2010 16:39:51 +0200

Hi Bernt, thanks a lot for this report - I believe I know
what was causing this and have fixed it, still on that branch of course.

- Carsten

On Apr 16, 2010, at 3:13 PM, Bernt Hansen wrote:

Found a bug.

I'll switch to this branch for regular work to try to find issues with

I'm running it on two versions of emacs uncompiled:

GNU Emacs 22.2.1 (i486-pc-linux-gnu, GTK+ Version 2.12.11) of 2008-11-09
on raven, modified by Debian


GNU Emacs (i386-mingw-nt5.1.2600) of 2009-11-03 on
LENNART-69DE564 (patched)

Clocking in doesn't work correctly.

I have a task like this

,----[ x.org ]
| * TODO foo
|   :CLOCK:
|   CLOCK: [2010-04-16 Fri 09:10]--[2010-04-16 Fri 09:11] =>  0:01
|   :END:
| ** TODO Bar baz
|    [2010-04-16 Fri 09:10]

if the parent task is clocking I can't clock in the subtask - the parent
task continues to clock and the point is moved to the headline of the
parent task.  Same behaviour on both versions.

Switching back to master until this is fixed since I can't function
without working clocking :)


Sebastian Rose <address@hidden> writes:

Carsten Dominik <address@hidden> writes:
I would appreciate if some people could check out the
`remove-compatibility-code' branch from repo.or.cz and report back
if they experience any problems with Emacs 22, 23, and 24, either
during compilation or while running.

I'm testing it with emacs 24.

The build went fine. Only one warning:

emacs -batch -q -no-site-file -eval "(progn (add-to-list (quote load-path) \"/usr/local/share/emacs/site-lisp\") (add-to-list (quote load-path) (expand-file-name \"./lisp/\")))" -f batch-byte- compile lisp/org-remember.el

In end of data:
org-remember.el:1156:1:Warning: the function `partial-completion- mode' is not
   known to be defined.
Wrote /home/sebastian/emacs/lisp/ext/org-mode/lisp/org-remember.elc

I reloaded Org-mode and tried remembering, published a project and it
seems to work so far. But I'll better remove the lisp/org/ directory
from my emacs tree and restart.

* One git question:

When I pulled, I got the message, that there is a new branch. But that
branch did not show up in the list `git branch' gives me.

Then I did:

sh$ git checkout origin/remove-compatibility-code
Note: moving to 'origin/remove-compatibility-code' which isn't a local branch

sh$ git branch
* (no branch)

sh$ git checkout -b remove-compatibility-code
Switched to a new branch 'remove-compatibility-code'

While this is all fine, and I'm on `remove-compatibility-code' now: will
that branch be updated when I pull the next time?

Best wishes

Emacs-orgmode mailing list
Please use `Reply All' to send replies to the list.

- Carsten

reply via email to

[Prev in Thread] Current Thread [Next in Thread]