[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] RE: Bug Report: refile and attachments

From: Colin Fraizer
Subject: [Orgmode] RE: Bug Report: refile and attachments
Date: Fri, 23 Jul 2010 07:06:45 -0400

I know it's not _exactly_ the same, but I re-filed it back to the original
file (C-c C-w) and then opened it successfully (C-c C-a o).  It didn't
prompt me (because there was only one attachment).

I just tried it with a new entry and attachment file (of the same type) and
it worked.  Hmn.

Oh, I see the problem.  In the failing case, the org files are in different
directories.  (I didn't realize it because they are both agenda files and I
was using the path-oriented interactive refilling.) I would expect the
refile to move the attachments to the target's attachment directory

[Sorry I didn't have time to debug the elisp myself.  I may look later if no
one jumps in before me.  I don't want to be a leech. 8-]

-----Original Message-----
From: Noorul Islam K M [mailto:address@hidden 
Sent: Friday, July 23, 2010 6:58 AM
To: Colin Fraizer
Cc: 'emacs-orgmode Mailinglist'
Subject: Re: Bug Report: refile and attachments

"Colin Fraizer" <address@hidden> writes:

> 1.       Exactly what I did
> I created an entry in an org file.
> I added an attachment to that entry.
> I used refile (C-c C-w) to move the entry to another org file.

Before doing this, can you try opening it from initial org file itself.

using C-c C-a o

Thanks and Regards

> I visited that file and attempted to open the attachment (C-c C-a o).
> 2.       What I expected:
> Because there was only one attachment associated with the entry, I
> it to open.
> 3.       What happened instead:
> I was prompted for an attachment name. Hitting <tab> showed "no match" in
> the minibuffer.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]