[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Help installing org-mode on a MAC please?

From: Erwin Panen
Subject: Re: [Orgmode] Help installing org-mode on a MAC please?
Date: Thu, 29 Jul 2010 15:37:29 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100711 Lightning/1.0b1 Thunderbird/3.0.6

Hi Juan,

Thanks a lot for your information and help!
I've edited my makefile according to your example, and everything ran without any error, so thanks a lot for that.

I must admit being somehow confused with all my previous trials dispersed over the past couple of months....
I know I've also installed fink, and I also have emacs under fink somewhere.
Next to that I also had Aquamacs, and Emcsformacosx.

In the mean time I decided to stick with Emacsformacosx for the time being, the reason being that I want to have as much "standard" behaviour as possible.

I'm also looking into setting up org-mode with MobileOrg. I use DropBox for cloud storage.

Now I copied over my .emacs config file from my winXP box to my Mac. Of course this is a lot different if only for the path and pathstructure.
Now I seem to find e.g. that emacsformacosx is incomplete (if I'm correct).
I don't find any bbdb nor the typical lisp folder....
(GNU Emacs 23.2.1 (x86_64-apple-darwin, NS apple-appkit-1038.29 of 2010-05-09 on black.local)

I also suffer from keyboard shortcut difficulties. (I'm on azerty / laptop keyb) I'm totally unable to get square brackets on my Mac. I can type them in other applications, but not in Emacs.
Do you know of a way around this?

Thanks for helping out,


On 12/07/2010 16:30, Juan wrote:
Hi Erwin,

I'm using Mac also (not Aquamacs emacs, but EmacsForMacOSX instead).

XEmacs is a completely different branch of Emacs, which I don't think
is available for OSX.

Then there is the text-mode emacs you run from the terminal.

And then there is the emacs you installed (Aquamacs), which runs on
its own graphics window (outside Terminal.app).

So don't confuse those 3 emacs versions.

You only need to install LaTeX if you want to build the documentation
(make doc). This is not strictly necessary.

Also, I have to modify the Makefile from org-mode to fit my emacs
installation. Aquamacs emacs should be similar, just check the exact
location of the Emacs application and change accordingly.

This is how my org-mode Makefile looks:


    # Name of your emacs binary

    # Where local software is found

    # Where local lisp files go.
    lispdir = $(prefix)/Contents/Resources/lisp/org

    # Where info files go.
    infodir = $(prefix)/Contents/Resources/info

The rest of the Makefile you leave as is.

Hope this helps.


On Sun, Jul 11, 2010 at 05:43:26PM +0200, Erwin Panen wrote:
I recently switched over to Mac, so I'm not familiar yet with all
inside-out Mac. At first I installed Aquamacs, but to be more
compatible I'd prefer to keep up with org-mode using git.

I managed to install homebrew, next git, and was able to use git to
get a clone of org-mode so that's allright.
(using git clone git://repo.or.cz/org-mode.git)
Next I tried to follow the FAQ: How do I keep current with Org mode

When I do: $ cd org-mode&&  make&&  make doc&&  make install
everything seems to go allright, but I get an error in the end
complaining about LateX not being installed.
So I installed MacTEX and tried running the above once more, with
the same error.

When I open up a terminal window and issue emacs, it opens up emacs
allright, but I find no xemacs? Is this not included with

reply via email to

[Prev in Thread] Current Thread [Next in Thread]