[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] [BUG] OrgTbl exports raw ampersands in HTML

From: Nick Dokos
Subject: Re: [Orgmode] [BUG] OrgTbl exports raw ampersands in HTML
Date: Wed, 13 Oct 2010 12:37:11 -0400

Ivan Vilata i Balaguer <address@hidden> wrote:

> (This is a rewrite of my previous post so it gets properly noticed as a
> bug. ;) )
> When generating HTML tables with ampersands in the text, OrgTbl outputs
> raw ampersands (&) instead of escaped ampersands (&amp;), which renders
> the file invalid.  This bug does not affect normal HTML generation when
> exporting standalone files.  I'm using Org version 7.01h.  I've attached
> a sample HTML file with an OrgTbl table in it so you can check for
> yourselves.  Thanks!

I confess I looked at your original report, was baffled by it, started
composing a reply but was distracted before sending it.

AFAIK, orgtbl-mode is a minor mode so that you can use org's table
generation facilities in other modes (e.g. text, or including a table
in a comment in a C/python/perl/foo source file, or in mail...)
In particular, it does not generate HTML. That is done by org's export
facilities. So either your description is inaccurate or my understanding
is flawed. Given the absence of responses, I suspect other people share
my bafflement.

It would help if you described the process you used exactly:

o I started with a file in foo major mode with these contents...

o I enabled orgtbl-mode and added a table like this...

o Then I did this-that-and-the-other to generate an HTML file which
  looks like this...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]