[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] "&" not converted to & when in equation enviroments

From: Lianheng Tong
Subject: [O] "&" not converted to & when in equation enviroments
Date: Fri, 3 Feb 2012 12:13:06 +0000

Dear all,

I am using org-mode version 7.7, and tried to export my org documents into html 
using org-export-html functions. I found that in normal texts and inline maths, 
the characters "&", "<" and ">" are converted correctly to "&amp;" "&lt;" and 
"&gt;" according to the definitions made by org-export-html-protect-char-alist.

However, the "&" and "<", ">" signs used in equations are NOT converted.  For 
example, if one has some thing like:

First, type & < >

This is an inline math $1 < y > 8$.

  x & = a + b \\
  y & < c - d

Will give the following segment in the exported html file:

First, type &amp; &lt; &gt;.

This is an inline math \(1 &lt; y &gt; 8\).

  x & = a + b \\
  y & < c + d

This produces an error when I tried to validate against the XHTML standard (as 
one would expect).

Is this an intended feature, and is there a switch/flag I can use to change 
this behaviour or is it a bug, and is there an easy fix? Thank you very much 
for your help in advance.

Best regards,


Lianheng Tong                                                             Tel: 
+44 20 7679 3302
London Centre For Nanotechnology                       Fax: +44 20 7679 0595
University College London                                        address@hidden
17–19 Gordon Street, London WC1H 0AH, U.K.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]