[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Isn't INHIBIT_X11R6_XIM declared properly?

From: NAKAJIMA Mikio
Subject: Isn't INHIBIT_X11R6_XIM declared properly?
Date: Mon, 21 Jul 2003 14:59:44 +0900
User-agent: Wanderlust/2.11.3 (Wonderwall) SEMI/1.14.5 (Awara-Onsen) FLIM/1.14.5 (Demachiyanagi) APEL/10.6 Emacs/21.3.50 (i586-pc-linux-gnu) MULE/5.0 (SAKAKI)

In GNU Emacs (i586-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2003-07-16 on pc-fj10
configured using `configure '--prefix=/home/minakaji' '--with-xpm' 
'--with-jpeg' '--with-tiff' '--with-gif' '--with-png' '--without-xim' 

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: C
  locale-coding-system: japanese-iso-8bit
  default-enable-multibyte-characters: t

When I compile the source, I get error:

  gcc -c -D_BSD_SOURCE     -Demacs -DHAVE_CONFIG_H -DUSE_LUCID  -I. 
-I/home/minakaji/progs/emacs/src   -D_BSD_SOURCE    -I/usr/X11R6/include        
-g xterm.c
  xterm.c: In function `xim_initialize':
  xterm.c:8143: `XRegisterIMInstantiateCallback_arg6' undeclared (first use in 
this function)
  xterm.c:8143: (Each undeclared identifier is reported only once
  xterm.c:8143: for each function it appears in.)
  xterm.c:8143: parse error before `xim_inst'
  make[1]: *** [xterm.o] Error 1

I think that is caused by a problem that INHIBIT_X11R6_XIM isn't
declared properly even if I use option '--without-xim' for
configure.  So I put `#define INHIBIT_X11R6_XIM' in src/config.h I
can compile the xterm.c.
NAKAJIMA Mikio <address@hidden>
home: http://www.asahi-net.or.jp/~gy2m-nkjm
diary: http://slashdot.jp/journal.pl?op=display&uid=5767

reply via email to

[Prev in Thread] Current Thread [Next in Thread]