[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Mark handling (Was: Changes to emacs/lisp/progmodes/grep.el)

From: Daniel Pfeiffer
Subject: Re: Mark handling (Was: Changes to emacs/lisp/progmodes/grep.el)
Date: Sat, 10 Jul 2004 21:54:40 +0200

Saluton, Moin,

Richard Stallman <address@hidden> skribis:

>     I don't care about this itself.  The bug is that after this, the mark is
>     not active.  If I do (for example)  drag click M->  it says "Mark set". 
>     But then M-w  complains "The mark is not active now".
> That does not happen for me.  The code in keyboard.c turns off the
> temporary transient mark mode after the next command, but it does not
> deactivate the mark.

I don't know why you don't get this.  I just rebuilt a new CVS Emacs, and even
with -q it still happens.

> Can you debug why the mark gets deactivated?

I haven't got a clue on how to debug something that depends on the events
Emacs gets.  Here are the events I give it:

<down-mouse-1> <mouse-movement> <mouse-movement> <drag-mouse-1> 
<down-mouse-1> <mouse-1> M-> M-w <f1> l

And the resulting messages:

Loading mwheel...done
(.emacs.d/cvs/src/emacs -q /etc/passwd)
Loading tooltip...done
Loading image...done
Note: file is write protected
Mark set
The mark is not active now
Loading help-mode...done

I also happens with writable files, but I chose one that would not load some
special mode.

coralament / best Grötens / liebe Grüße / best regards / elkorajn salutojn
Daniel Pfeiffer

lerne / learn / apprends / lär dig / ucz się    Esperanto:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]