[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Odd value for auto_save_mode_bits

From: Klaus Zeitler
Subject: Odd value for auto_save_mode_bits
Date: Fri, 5 Nov 2004 12:27:46 +0100 (MET)


Since a few days I'm having auto-save problems. I think this is caused
by the following lines in function auto_save_1 (fileio.c)

  else if (! NILP (current_buffer->filename))
    /* Remote files don't cooperate with stat.  */
    auto_save_mode_bits = XINT (Ffile_modes (current_buffer->filename)) | 0600;

if the filename doesn't yet exist, Ffile_modes (current_buffer->filename)
returns Qnil, i.e. auto_save_mode_bits will be set to 415104.
An open call that uses this value for parameter mode results in EACCES.

In GNU Emacs (sparc-sun-solaris2.8, Motif Version 2.1.0)
 of 2004-11-05 on sfsws4
Distributor `Sun Microsystems, Inc.', version 11.0.6410
configured using `configure '--with-gcc' 
'--x-libraries=/usr/openwin/lib:/usr/local/gnu/lib' '--with-pop' 'CC=gcc''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: C
  locale-coding-system: nil
  default-enable-multibyte-characters: t

Major mode: Lisp Interaction

Minor modes in effect:
  tool-bar-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  unify-8859-on-encoding-mode: t
  utf-translate-cjk-mode: t
  line-number-mode: t

Recent input:
<help-echo> <help-echo> <help-echo> <menu-bar> <help-menu> 

Recent messages:
Loading mwheel...done
(/usr/local/gnu/cvs/head/bin/emacs -q --no-site-file)
Loading tool-bar...done
Loading image...done
Loading tooltip...done
For information about the GNU Project and its goals, type C-h C-p.
Loading emacsbug...done

reply via email to

[Prev in Thread] Current Thread [Next in Thread]