[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: default value 'w3 of mm-text-html-renderer

From: Roland Winkler
Subject: Re: default value 'w3 of mm-text-html-renderer
Date: Mon, 17 Jan 2005 19:07:26 +0100

On Mon Jan 17 2005 Stefan Monnier wrote:
> >> Well, if you have w3 installed, Gnus will use it.  If you have w3
> >> installed, but it doesn't work, then Gnus can't really be expected to
> >> guess that.  Either remove w3 or change the value of
> >> `mm-text-html-renderer'.
> > Can you use w3 with a recent version of GNU CVS emacs?
> > When I start it with M-x w3 I get the error message
> >   (void-function url-register-protocol)
> According to the URL ChangeLog, url-register-protocol hasn't ever been
> added/removed/changed/touched/...
> Now, Google says otherwise (it says that it was mentioned at least in
> xemacs-19.16/lisp/w3/url-vars.el), but that was a long time ago.
> What version of W3 are you using?

I just noticed in the NEWS file of GNU CVS Emacs:

** The URL package (which had been part of W3) is now part of Emacs.

Did this change break anything for a "standard" w3 installation
which includes its old version of the URL package?

I looked into this when I noticed that the error messages I get
depend on where I put the lisp directory for w3 in load-path. But up
to now I have not fully understood what is happening.

I am still curious: Is it only me who cannot use w3 with a recent
version of GNU CVS emacs or are there others who can confirm that?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]