[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latin-1 chars not recognized for default french flyspell dict

From: Stefan Monnier
Subject: Re: Latin-1 chars not recognized for default french flyspell dict
Date: Fri, 18 Mar 2005 16:33:37 -0500
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

> On the machines here, the default ispell dictionary is French.
> This confuses flyspell as the example below shows:

>    % emacs -q ~/tmp/foo.txt
>    M-x flyspell-mode RET
>    chocolat
>    chocolate
>    problème

> the first word is accepted as correct while the second is highlighted
> as a typo (this is just to show that it's indeed using the French
> dictionary), but the third also gets highlighted, tho in a messed up
> way: only the "probl" part gets highlighted, because flyspell
> obviously didn't consider the accented char as being part of the word.

BTW, I see that the problem is linked to the fact that the entry in
ispell-dictionary-alist-1 corresponding to the default dictionary (nil)
assumes the default is English.

I'm currently using the patch below to good effect (on both a machine where
the default is French and on another machine where the default is English).


--- orig/lisp/textmodes/ispell.el
+++ mod/lisp/textmodes/ispell.el
@@ -509,7 +509,7 @@
  '((nil                                        ; default (English.aff)
-    "[A-Za-z]" "[^A-Za-z]" "[']" nil ("-B") nil iso-8859-1)
+    "\\w" "\\W" "[']" nil ("-B") nil iso-8859-1)
    ("american"                         ; Yankee English
     "[A-Za-z]" "[^A-Za-z]" "[']" nil ("-B") nil iso-8859-1)
    ("brasileiro"                       ; Brazilian mode

reply via email to

[Prev in Thread] Current Thread [Next in Thread]