[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make: syntax error before "G_GNUC_SENTINEL"

From: Jan D.
Subject: Re: make: syntax error before "G_GNUC_SENTINEL"
Date: Tue, 5 Jul 2005 17:11:17 +0200

I just did cvs up and ./configure --with-x-toolkit=gtk without a
problem, but make (without and with bootstrap) bailed out with the
following errors. I used the same gcc (3.3.5), gtk2 (2.6.4) and make (3.80) (all from SUSE 9.3) as I did with my previous successful build (the one with which I'm posting this) and didn't get these errors then
or ever before.  Can anyone help?

In file included from /opt/gnome/include/gtk-2.0/gdk-pixbuf/gdk-
                 from /opt/gnome/include/gtk-2.0/gdk/gdkcursor.h:5,
                 from /opt/gnome/include/gtk-2.0/gdk/gdk.h:31,
                 from /opt/gnome/include/gtk-2.0/gtk/gtk.h:31,
                 from xterm.h:46,
                 from dispnew.c:56:
/opt/gnome/include/gtk-2.0/gdk-pixbuf/gdk-pixbuf-core.h:163: error:
syntax error before "G_GNUC_SENTINEL"

Did you update your Suse system between Emacs compiles?

As a matter of fact, yes -- and that's what caused the problem...

Try looking for G_GNUC_SENTINEL in the include files at
/usr/include, /usr/local/ include, /usr/X11R6/include and possibly

It's not there, nor anywhere else.  Among the updated packages was
glib2, updated from 2.6.3 to 2.7.0.  G_GNUC_SENTINEL is defined in
/opt/gnome/include/glib-2.0/glib/gmacros.h in the earlier version,
but not in the later version.  In fact, the only difference between
the two versions of gmacros.h is this:

I think you have incompatible versions. The 2.7.* versions and 2.6.* versions are not ment to be mixed. If you use Gtk 2.6.4 you shall use a glib version 2.6.* also. Or if you use glib 2.7.*, you need a Gtk 2.7.* also. In addition to that, it seems that Suse has altered the glib 2.6.3 source. G_GNUC_SENTINEL is not in the source for glib 2.6.3 as found on www.gtk.org.

You can find the current versions here: ftp://ftp.gtk.org/pub/gtk/ v2.7/, and for 2.6, here: ftp://ftp.gtk.org/pub/gtk/v2.6/.

I suggest downgrading back to the previous version of glib. 2.7 is the unstable series, so unless you really need something that has been added or fixed in 2.7, there is no reason to use 2.7.

    Jan D.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]