[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU Emacs 22.0.50 fails to find ä in different ISO Latin encodings

From: Kenichi Handa
Subject: Re: GNU Emacs 22.0.50 fails to find ä in different ISO Latin encodings
Date: Tue, 19 Sep 2006 12:58:31 +0900
User-agent: SEMI/1.14.3 (Ushinoya) FLIM/1.14.2 (Yagi-Nishiguchi) APEL/10.2 Emacs/22.0.50 (i686-pc-linux-gnu) MULE/5.0 (SAKAKI)

In article <address@hidden>, Peter Dyballa <address@hidden> writes:

> Hello!
> Launched with -Q

>       unify-8859-on-decoding-mode is nil
>       unify-8859-on-encoding-mode is t

> I start i-search in an Unicode encoded buffer (*Help*). In an ISO  
> 8859-1 encoded buffer ä and Ä are found, also in ISO 8859-10, ISO  
> 8859-13 (except for Ä), ISO 8859-14, and ISO 8859-16 encoded buffers,  
> but fails in ISO 8859-2, ISO 8859-3, ISO 8859-4, ISO 8859-9, and ISO  
> 8859-15. It is similiar to ö and ü, accept that these are not found  
> in the ISO 8859-14 encoded buffer. Changing unify-8859-on-decoding- 
> mode's value makes no difference.

This is the story I remember.

A while ago, I proposed to change isearch so that it
translates characters by translation-table-for-input to
solve such a problem, but there raised an objection that
read-char should do that translation.  RMS asked to check if
such a change to read-char is surely safe or not, but as
such a check is very difficult and time-consuiming, no one
took on the job.

So, this problem is still unfixed.

I again propose to change isearch.  When we know that
changing read-char is safe in the future, we can cancel that
change in isearch.

Kenichi Handa

reply via email to

[Prev in Thread] Current Thread [Next in Thread]