[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: a bug in ps-print

From: Eli Zaretskii
Subject: Re: a bug in ps-print
Date: Sun, 13 May 2007 23:23:03 +0300

> Date: Sun, 13 May 2007 11:32:36 -0300
> From: Vinicius Jose Latorre <address@hidden>
> Cc: address@hidden, Kenichi Handa <address@hidden>
> 1. emacs-23 -nw -Q
> 2. M-x ps-print-buffer-with-faces RET
>       `ps-default-fg' and `ps-default-bg' have the same color.
>       Text won't appear on page.  Please, check these variables.
> 3. M-: (ps-frame-parameter nil 'foreground-color) RET
>       ==> "unspecified-bg"
> 3. M-: (ps-frame-parameter nil 'background-color) RET
>       ==> "unspecified-fg"
> If I tried with "emacs-23 -nw", it works, that is, foreground and 
> background color are set properly.
> I tested also with Emacs 22 with the same results.
> It seems this is a problem with initial frame properties setting when 
> Emacs is activated in xterm.
> Could someone who knows this better checks the initial frame color 
> property in this situation and see if there is a way to set initial 
> frame color to a valid color?

There is no way to query a text terminal about its default foreground
and background colors, at least not a way that is known to us.  That's
why we use those strange unspecified-fg and unspecified-bg designators
for them.

Why do you need to have a valid color specification there?  I think
ps-print should simply use black on white for this case.  If this will
fail to work, please explain why.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]