[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: flyspell-mode fails in non-existing directory

From: Nikolaj Schumacher
Subject: Re: flyspell-mode fails in non-existing directory
Date: Mon, 14 May 2007 11:27:21 +0200

martin rudalics <address@hidden> writes:

after finding a new file in a not yet created directory, flyspell- mode
fails with:

True, but when "finding" that file Emacs should have told you

Use M-x make-directory RET RET to create the directory and its parents

which you apparently ignored ;-) and when trying to save the buffer Emacs
would tell you

basic-save-buffer-2: ...: no such directory

I already knew that the directory didn't exist and how to create it.
But why should I have to save the file to run flyspell, when I can even
use it on buffers with no files associated?
Also, I call flyspell-mode in a major-mode hook (or is there anything
wrong with that?), so the error occurs before I even could save it.

ispell seems to work around this for synchronous processes, but
apparently not for `start-process'.

I presume both ispell and flyspell use asynchronous processes on your
system. Moreover the same error should be issued for synchronous ones. In fact, both `start-process' and `call-process' have identic code here:

True, those two have identical code.  Yet `ispell-call-process' is a
wrapper used by ispell to "defend against bad `default-directory'".
There is no such wrapper for in `ispell-start-process'.

Nikolaj Schumacher

reply via email to

[Prev in Thread] Current Thread [Next in Thread]