[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ft-devel] freetype2 installation problems in Cygwin

From: VMarcano
Subject: Re: [ft-devel] freetype2 installation problems in Cygwin
Date: Sat, 13 Oct 2012 09:47:36 -0700 (PDT)

Hi, Mr. Suzuki:

Firstly, I have to tell you that I was reading the
C:\cygwin\usr\src\freetype\freetype-2.4.9\docs\INSTALL file, trying to find
out reasons of the problem.
I berified the version of the GNI Make tool installed in my PC, which is:

$ make -version
GNU Make 3.82.90

Then, I removed and reextracted all files and folder of freetype2, from the
tar file; afterwards, I tried to make the library again. Following appears
the ending part of the command output:

$ make
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating ./config.status
config.status: creating
config.status: creating
config.status: creating freetype-config
config.status: creating freetype2.pc
config.status: creating ftconfig.h
config.status: executing libtool commands

address@hidden /usr/src/freetype/ft2demos-2.4.9

Then, I used the command
$ make install

And  on the screen appeared a long listing, which terminated with:
/usr/bin/install -c -m 644 ./builds/unix/ftconfig.h                        \
/usr/bin/install -c -m 644 /usr/src/freetype/freetype-2.4.9/objs/ftmodule.h     
/usr/bin/install -c -m 755 ./builds/unix/freetype-config \
/usr/bin/install -c -m 644 ./builds/unix/freetype2.m4 \
/usr/bin/install -c -m 644 ./builds/unix/freetype2.pc \

address@hidden /usr/src/freetype/freetype-2.4.9

No error messages nor warnings were appreciated in that listing. However,
when I tried to make the sample programs contained in ftdemos-2.4.9.tar.bz2,
I received the following message:

address@hidden /usr/src/freetype/ft2demos-2.4.9
$ make
Please compile the library before the demo programs!

Trying not to give up, I attempted to build some of the demo programs
manually. I achieved to compile and link ftbench.c, by using:
address@hidden /usr/src/freetype/ft2demos-2.4.9/src
$ g++ -O0 -g3 -Wall -c -fmessage-length=0 -MMD -MP -MF"" -c  ftbench.c 

And …

$ g++ -o ftbench ftbench.o  /usr/lib/libfreetype.dll.a

It was successful. In fact, I showed below the main menu that presents
ftbench at runtime.

address@hidden /usr/src/freetype/ft2demos-2.4.9/src
$ ./ftbench
ftbench: bench some common FreeType paths

Usage: ftbench [options] fontname

   -C : compare with cached version if available
   -c : max iteration count for each test (0 means time limited)
   -f : load flags (hexadecimal)
   -i : first index to start with (default is 0)
   -m : max cache size in KByte (default is 1024)
   -p : preload font file in memory
   -r : render mode (default is FT_RENDER_MODE_NORMAL)
   -s : face size (default is 10)
   -t : max time per bench in seconds (default is 2)
   -b tests : perform chosen tests (default is all)
      a : Load a glyph
      b : Load advance widths
      c : Render a glyph
      d : Get FT_Glyph
      e : Get glyph cbox
      f : Get glyph index
      g : Iterate CMap
      h : Open a new face
      i : Embolden

Nevertheless, when I tried to do the same to others, such as ftstring.c and
ftview.c, which have external references to be solved, I achieved to compile
the source into an object file, but linking process reported the errors
showed below:

address@hidden /usr/src/freetype/ft2demos-2.4.9/src
$ g++ -O0 -g3 -Wall -c -fmessage-length=0 -MMD -MP -MF"" -c  ftview.c -I. 
-I../graph/ -I/usr/include/freetype2/ -I /usr/include/glib-2.0/glib/

address@hidden /usr/src/freetype/ft2demos-2.4.9/src
$ g++ -o ftview ftview.o  ftcommon.o ../graph/grblit.o ../graph/grdevice.o
../graph/grfont.o  ../graph/grinit.o   ../graph/grobjs.o ../graph/gblender.o
-lfreetype -lz -lbz2 -lglib
ftview.o: In function `Render_Text':
/usr/src/freetype/ft2demos-2.4.9/src/ftview.c:496: undefined reference to
/usr/src/freetype/ft2demos-2.4.9/src/ftview.c:506: undefined reference to
ftview.o: In function `write_header':
/usr/src/freetype/ft2demos-2.4.9/src/ftview.c:1154: undefined reference to
ftview.o: In function `parse_cmdline':
/usr/src/freetype/ft2demos-2.4.9/src/ftview.c:1287: undefined reference to
ftcommon.o: In function `_Z17FTDemo_String_SetP13FTDemo_HandlePKc':
/usr/src/freetype/ft2demos-2.4.9/src/ftcommon.c:973: undefined reference to
../graph/grblit.o: In function
/usr/src/freetype/ft2demos-2.4.9/graph/grblit.c:1914: undefined reference to
`gblender_blit_init(GBlenderBlitRec_*, GBlenderRec_*, int, int,
GBlenderSourceFormat, unsigned char const*, int, int, int,
GBlenderTargetFormat, unsigned char*, int, int, int)'
collect2: ld devolvió el estado de salida 1 (returned exit status 1)

address@hidden /usr/src/freetype/ft2demos-2.4.9/src

I searched Internet for those errors without good results.

In summary, I don’t know why the tool male looks not to see the linrary
installed, and, on the other hand, how to solve the external references
which avoid to complete the linking process.

I will appreciate any helo.



suzuki toshiya wrote:
> Hi Marcano,
> Please describe the commands that you've executed, and what errors you've
> got.
> Regards,
> mpsuzuki
> VMarcano wrote:
>> Hi, everybody.
>> I am trying to use freetype2 libraru in Cygwin. I downloaded
>> freetype-2.4.9.tar.bz2 and extracted its contents to a folder in my
>> machine
>> (under /usr branch), but when I try to install it, a message appears on
>> the
>> screen, indicating that "" cannot be found, and installation is
>> aborted. 
>> I tried "find /usr -iname", but no findinjs were reported.
>> Could any of you help me, please?
>> Regards,
>> Marcano
>> P.D.: I have not too mucuch experoece in unix-like environment, but I
>> have
>> installed and used other libraries, like OpenCV, SDL and OpenGL, un the
>> same
>> Cygwin platform, successfully.
> _______________________________________________
> Freetype-devel mailing list
> address@hidden

View this message in context:
Sent from the Freetype - Dev mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]