[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

g-wrap on cygwin

From: Edgar Vasquez
Subject: g-wrap on cygwin
Date: Wed, 13 Aug 2008 00:37:01 -0500

I don't know if this who I should be e-mailing about this problem, but I don't know where else to go. I have been trying to compile g-wrap 1.9.11 on cygwin for a while, but have never succeeded. The building process stops during make with this message:

///usr/include/stdio.h:517: warning: no previous prototype for '__sgetc_r'
 gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../g-wrap -I../.. -I../../lib -I../../guile -I/usr/local/lib/libffi-3.0.6/include -g -O2 -Wall -Wmissing-prototypes -std=gnu99 -MT guile-wct.lo -MD -MP -MF .deps/guile-wct.Tpo -c guile-wct.c -o guile-wct.o >/dev/null 2>&1
if /bin/sh ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../g-wrap  -I../.. -I../../lib -I../../guile   -I/usr/local/lib/libffi-3.0.6/include   -g -O2 -Wall -Wmissing-prototypes -std=gnu99 -MT guile-compatibility.lo -MD -MP -MF ".deps/guile-compatibility.Tpo" -c -o guile-compatibility.lo guile-compatibility.c; \
        then mv -f ".deps/guile-compatibility.Tpo" ".deps/guile-compatibility.Plo"; else rm -f ".deps/guile-compatibility.Tpo"; exit 1; fi
 gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../g-wrap -I../.. -I../../lib -I../../guile -I/usr/local/lib/libffi-3.0.6/include -g -O2 -Wall -Wmissing-prototypes -std=gnu99 -MT guile-compatibility.lo -MD -MP -MF .deps/guile-compatibility.Tpo -c guile-compatibility.c  -DDLL_EXPORT -DPIC -o .libs/guile-compatibility.o
 gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../g-wrap -I../.. -I../../lib -I../../guile -I/usr/local/lib/libffi-3.0.6/include -g -O2 -Wall -Wmissing-prototypes -std=gnu99 -MT guile-compatibility.lo -MD -MP -MF .deps/guile-compatibility.Tpo -c guile-compatibility.c -o guile-compatibility.o >/dev/null 2>&1
/bin/sh ../../libtool --tag=CC --mode=link gcc  -I/usr/local/lib/libffi-3.0.6/include   -g -O2 -Wall -Wmissing-prototypes -std=gnu99  -no-undefined -o libgwrap-guile-runtime.la -rpath /usr/local/lib -version-info 2:0:0 -no-undefined guile-runtime.lo guile-wct.lo guile-compatibility.lo ../../g-wrap/libgwrap-core-runtime.la -lguile -lltdl  -L/usr/lib -L/usr/bin -L/usr/lib/w32api -lgmp -lcrypt -lm -lltdl -L/usr/local/lib -lffi   ../../lib/libgnu.la

*** Warning: This system can not link to static lib archive /usr/lib/libffi.la.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.
gcc -shared  .libs/guile-runtime.o .libs/guile-wct.o .libs/guile-compatibility.o -Wl,--whole-archive ../../lib/.libs/libgnu.a -Wl,--no-whole-archive  ../../g-wrap/.libs/libgwrap-core-runtime.dll.a -L/usr/local/lib /usr/lib/libguile.dll.a -L/usr/lib -L/usr/bin -L/usr/lib/w32api /usr/lib/libgmp.dll.a -lcrypt /usr/lib/libltdl.dll.a  -o .libs/cyggwrap-guile-runtime-2.dll -Wl,--enable-auto-image-base -Xlinker --out-implib -Xlinker .libs/libgwrap-guile-runtime.dll.a
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../i686-pc-cygwin/bin/ld: warning: auto-importing has been activated without --enable-auto-import specified on the command line.
This should work unless it involves constant data structures referencing symbols from auto-imported DLLs..libs/guile-runtime.o: In function `do_ffi_call':
/home/Edgar/build/g-wrap-1.9.11/guile/g-wrap/guile-runtime.c:597: undefined reference to `_ffi_call'
Info: resolving _scm_class_top by linking to __imp__scm_class_top (auto-import)
Info: resolving _scm_class_method by linking to __imp__scm_class_method (auto-import)
Info: resolving _scm_class_generic by linking to __imp__scm_class_generic (auto-import)
Info: resolving _scm_module_goops by linking to __imp__scm_module_goops (auto-import)
Creating library file: .libs/libgwrap-guile-runtime.dll.a
collect2: ld returned 1 exit status
make[4]: *** [libgwrap-guile-runtime.la] Error 1
make[4]: Leaving directory `/home/Edgar/build/g-wrap-1.9.11/guile/g-wrap'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/Edgar/build/g-wrap-1.9.11/guile/g-wrap'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/Edgar/build/g-wrap-1.9.11/guile'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/Edgar/build/g-wrap-1.9.11'
make: *** [all] Error 2

Any help would be appreciated, and if this is the wrong place to ask about this, then please point me in the right direction. Thank you.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]