[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Gcl-devel] Problem installing Gcl under Windows

From: Mike Thomas
Subject: RE: [Gcl-devel] Problem installing Gcl under Windows
Date: Mon, 10 Jan 2005 06:56:57 +1000

Hi again.

Thanks for persevering.  Now you hopefully see the value in CCing your GCL
related emails to the mailing list!!!

| -----Original Message-----
| From: address@hidden [mailto:address@hidden
| Sent: Monday, 10 January 2005 5:43 AM
| To: mike.thomas
| Subject: RE: [Gcl-devel] Problem installing Gcl under Windows
| I'm sorry I've not replayed to you. I saw your email yesterday
| only on the gcl
| devel site, because I've not received it in my mailbox.

Sorry about that - I didn't see a bounce from your email address and so
assumed it had gone through.  I probably accidentally deleted it amongst the
dozens of junk emails.

| I have already tried some days ago the command:
|  saved_ansi_gcl <enter>
| but the gcl prompt does not appear. Only an empty line is printed
| and then  the
| dos prompt appears.
| No error message appears.
| if I run that command adding -help or --help no message appears.

Could you please describe your hardware and OS in detail?  For example;
processor, RAM, space left on disk, exact version of Windows 2000 etc etc.
I'm wondering whether your version of Windows is a member of the Windows
95/98/ME family rather than the Windows NT family (I use Windows 200
Professional and Windows XP to develop and test GCL, both of which are
members of the NT family.)

GCL should run on Windows 98 and later.

| I tried to compile it but doesn't work. I tried msys

Could you please send me the logs produced by the following steps:

1. Make sure that your MSYS PATH environment variable does not contain any
Cygwin directories.

2. Run these exact commads at your MSYS prompt:

     msysinfo >msysinfo.log 2>&1
     make clean
     time configure --enable-ansi >configure.log 2>&1
     time make >make.log 2>&1

| and
| cygwin(gcc 3.4.2 e
| binutils 2.15.90). I even tried to replace the cygwin compiler
| files with gcc 3.3.1 with binutils
| version 2.14.90 but in that way it doesn't find the libraries,
| even the includes.
| I installed gcc 3.3.1 and binutils 2.14.90 outside cygwin and
| added the current
| release of mingw, but compiling it , it says there  aren't some
| .h files . I
| added the cygwin versions (for example of ioctl.h) but some
| variables aren't
| declared such as F_GETLF , F_SETLF, O_NONBLOCK.

This is definitely not a good course of action as Cygwin is neither
supported as a build host nor as a target for GCL.  After applying that
patch I sent, MSYS with the latest MinGW32 gcc, binutils and headers should
do the job fine.

In any case, those logs will help us to work out what is going wrong.
Please keep up the good work.


Mike Thomas.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]