[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] Patch: adapt to newer autoconf versions

From: Jerry James
Subject: [Gcl-devel] Patch: adapt to newer autoconf versions
Date: Thu, 20 Nov 2008 09:19:18 -0700

If autoconf 2.61 is used to process the current configure.in, it
produces a script containing illegal shell script syntax, causing a
script failure at runtime.  This is due to some obsolete autoconf
usages within configure.in.  This patch fully updates configure.in for
use by autoconf 2.61.  Let me explain a few bits of the patch.

I added AC_PROG_EGREP, because AC_EGREP_HEADER (formerly
AC_HEADER_EGREP) now expands to an expression that includes
"$(EGREP)", which isn't set unless AC_PROG_EGREP is run.

I added AC_GNU_SOURCE and a corresponding #undef in acconfig because
some math functions (e.g., isnormal) aren't defined unless _GNU_SOURCE
is defined.  There was already a workaround in the script for this,
but it broke in a couple of cases on my Fedora 9 machine.

I reordered a few statements to make the "checking ..." messages and
their corresponding results be on the same line.

Quite a few obsolete macros were converted to their new forms.

There were a number of cases of strings quoted with quote marks
instead of square brackets.

I replaced the checks for endianness and alloca with the now builtin
autoconf checks.

My editor didn't like all the lines with trailing whitespace nor
spaces in front of tab characters.  I finally got tired of it whining
at me and let it clean all that up, so there are a bunch of lines with
whitespace-only changes.
Jerry James

Attachment: gcl-2.6.7-autoconf.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]