[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [glob2-devel] feedback on Globulation 2 (long, with many topics)

From: Stéphane Magnenat
Subject: Re: [glob2-devel] feedback on Globulation 2 (long, with many topics)
Date: Fri, 6 Apr 2007 10:53:17 +0200
User-agent: KMail/1.9.6

> >> glob2 (version 0.8.22) uses 1.2 gigabytes of memory just to edit a 512
> >> by 512 map!
> >
> > Is this with cached memory, or only what is really used.
> > Try to use the "free" command to estimate how much is really used.
> The virtual memory used is about 1.6 gigabytes.  Shortly after loading
> the map it reports around 1.2 gigabytes resident, which I assume means
> that other programs running on the machine needed to quickly reclaim
> about 0.4 gigabytes just to keep running.  Basically everything else
> on my machine gets paged or swapped out during the process of loading
> the map, which takes quite some time.
> In comparison, glob2 version 0.8.21 uses about 80 megabytes virtual
> memory and about 60 megabytes resident memory to edit a 512 by 512
> map.  This is a memory usage increase of about a factor of 20.  The
> difference shows in that it takes just a couple of seconds to load a
> 512 by 512 map with the older version, but up to a minute for the
> latest version.

This is bad, very bad! :-(
Bradley, do you have any idea why this can happen?

> By the way, glob2 version 0.8.21 can't see any maps I've created with
> glob2 version 0.8.22, and glob2 version 0.8.22 can't see any maps I've
> created with glob2 versions 0.8.21 or 0.8.16.  The maps simply don't
> show up in the list of available maps for editing or playing.  glob2
> version 0.8.22 seems to have no trouble seeing the maps that came with
> the 0.8.21 .deb, because those are the ones I'm using now.  It's just
> the randomly generated maps that I created that seem incompatible.
> Are they supposed to work across versions 0.8.16, 0.8.21, and/or
> 0.8.22?

forward compatibility is not supported but backward one should be, so it is 
probably a bug.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]