[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [glob2-devel] mercurial updated to 0.9.3

From: Kai Antweiler
Subject: Re: [glob2-devel] mercurial updated to 0.9.3
Date: Fri, 27 Apr 2007 20:32:40 +0200

I have searched for the abort message:
# for i in $(equery f mercurial);do grep -l "authorization failed" $i;done

   223     def do_cmd(self, cmd, **args):
   224         data = args.pop('data', None)
   225         headers = args.pop('headers', {})
   226         self.ui.debug(_("sending %s command\n") % cmd)
   227         q = {"cmd": cmd}
   228         q.update(args)
   229         qs = '?%s' % urllib.urlencode(q)
   230         cu = "%s%s" % (self._url, qs)
   231         try:
   232             if data:
   233                 self.ui.debug(_("sending %s bytes\n") %
   234                               headers.get('content-length', 'X'))
   235             resp = urllib2.urlopen(urllib2.Request(cu, data, headers))
   236         except urllib2.HTTPError, inst:
   237             if inst.code == 401:
   238                 raise util.Abort(_('authorization failed'))
   239             raise

I guess your repository is correct.
Maybe mercurial wants a newer urllib2 (should be part of the python package).
Do you have python-2.3 or greater installed?
That is the only dependency that I see listed in the gentoo mercurial package.
But they list it also for mercurial-0.9.1 .

We should check what I suggested in my last mail.
And then ask the guys from mercurial for help.

We could also check if a new repository (with 1 file in it) has the
same problems.
Then we could totally rule out that the clone went wrong.
Kai Antweiler

reply via email to

[Prev in Thread] Current Thread [Next in Thread]