[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gluster-devel] Centos 4.4 clients fail to connect to server

From: Anand Avati
Subject: Re: [Gluster-devel] Centos 4.4 clients fail to connect to server
Date: Thu, 10 May 2007 22:35:00 +0530

 is this during fetch spec stage? or are you using spec from a local
file? some connection related code was fixed in the source repository,
could you please confirm if the issue is seen from the TLA checkout?


2007/5/10, Justin McAleer <address@hidden>:
I'm trying to set up a simple NFS-like test setup with a couple of
CentOS 4.4 servers. The server (brick) is working fine, but I cannot get
the client side to work. It seems to not even successfully open a tcp
connection. CentOS 5 clients are working with the 4.4 server (brick).
Here is the debug output from glusterfs:

May 10 09:32:16] [DEBUG/client-protocol.c:2796/init()]
protocol/client:defaulting transport-timeout to 120
[May 10 09:32:16] [DEBUG/transport.c:83/transport_load()]
libglusterfs/transport:attempt to load type tcp/client
[May 10 09:32:16] [DEBUG/transport.c:88/transport_load()]
libglusterfs/transport:attempt to load file
[May 10 09:32:16] [DEBUG/tcp-client.c:174/tcp_connect()] transport: tcp:
:try_connect: socket fd = 7
[May 10 09:32:16] [DEBUG/tcp-client.c:196/tcp_connect()] transport: tcp:
:try_connect: finalized on port `1023'
[May 10 09:32:16] [DEBUG/tcp-client.c:220/tcp_connect()]
tcp/client:try_connect: defaulting remote-port to 6996
[May 10 09:32:16] [DEBUG/tcp-client.c:255/tcp_connect()]
tcp/client:connect on 7 in progress (non-blocking)
[May 10 09:32:16] [DEBUG/tcp-client.c:293/tcp_connect()]
tcp/client:connection on 7 still in progress - try later

The server (brick) never sees an incoming connection. I'm running
1.3.0-pre3 on x86_64, and tried two different machines as clients. In
fact, the current brick was originally my client (which showed the same
behavior as above). Any ideas?

I tried turning on the trace translator, but it didn't appear to do
anything, and glusterfs segfaulted when I ran umount in another terminal
to "unhang" the process.

Gluster-devel mailing list

Anand V. Avati

reply via email to

[Prev in Thread] Current Thread [Next in Thread]