[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gluster-devel] glusterFS on rocks4.3?

From: Ricardo Garcia Mayoral
Subject: Re: [Gluster-devel] glusterFS on rocks4.3?
Date: Fri, 18 Apr 2008 19:55:44 +0200
User-agent: Thunderbird (X11/20080306)

We have not been successful so far. First, we couldn't find the fuse-2.7.0-glfs8.tar.gz tarball, so we tried with fuse-2.7.0-glfs7.tar.gz and fuse-2.7.2glfs9.tar.gz. Both installs gave no problem, but when trying to install glusterfs-1.3.7.tar.gz, during the 'make' step we would get the error:

make[2]: Entering directory `/root/gluster/glusterfs-1.3.7/glusterfs-fuse/src' if gcc -DPACKAGE_NAME=\"glusterfs\" -DPACKAGE_TARNAME=\"glusterfs\" -DPACKAGE_VERSION=\"1.3.7\" -DPACKAGE_STRING=\"glusterfs\ 1.3.7\" -DPACKAGE_BUGREPORT=\"address@hidden" -DPACKAGE=\"glusterfs\" -DVERSION=\"1.3.7\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DYYTEXT_POINTER=1 -DHAVE_LIBPTHREAD=1 -DHAVE_LIBDL=1 -DHAVE_LIBFUSE=1 -DHAVE_LIBIBVERBS=1 -DHAVE_BACKTRACE=1 -DHAVE_MALLOC_STATS=1 -DHAVE_SET_FSID=1 -DHAVE_TV_NSEC=1 -DHAVE_ARGP=1 -DHAVE_LLISTXATTR=1 -DHAVE_FDATASYNC=1 -DHAVE_SYS_EPOLL_H=1 -DHAVE_SYS_XATTR_H=1 -I. -I. -D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=26 -D_GNU_SOURCE -I../../libglusterfs/src -DDATADIR=\"/share/apps/var\" -DCONFDIR=\"/share/apps/etc/glusterfs\" -fPIC -Wall -pthread -g -O2 -MT glusterfs.o -MD -MP -MF ".deps/glusterfs.Tpo" -c -o glusterfs.o glusterfs.c; \ then mv -f ".deps/glusterfs.Tpo" ".deps/glusterfs.Po"; else rm -f ".deps/glusterfs.Tpo"; exit 1; fi
glusterfs.c:20:18: fuse.h: No such file or directory
make[2]: *** [glusterfs.o] Error 1
make[2]: Leaving directory `/root/gluster/glusterfs-1.3.7/glusterfs-fuse/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/gluster/glusterfs-1.3.7/glusterfs-fuse'
make: *** [all-recursive] Error 1

We tried to do the fuse './configure' with '--enable-kernel-module', but the error is still the same. For all configures we have used '--prefix=/share/apps', since that is a directory exported to all the nodes.

Using 'locate', we see we have
but it seems that the compilation of glusterfs is not able to find them.

Any ideas? Thanks.

Ricardo Garcia Mayoral
Computational Fluid Mechanics
ETSI Aeronauticos, Universidad Politecnica de Madrid
Pz Cardenal Cisneros 3, 28040 Madrid, Spain.
Phone: (+34) 913363291  Fax: (+34) 913363295
e-mail: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]