[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gluster-devel] Problem with little write/read files in Gluster 3.0.

From: Gordan Bobic
Subject: Re: [Gluster-devel] Problem with little write/read files in Gluster 3.0.0
Date: Thu, 28 Jan 2010 16:49:48 +0000
User-agent: Thunderbird (X11/20090625)

Anand Avati wrote:
On Thu, Jan 28, 2010 at 4:44 PM, Gordan Bobic <address@hidden> wrote:

Thanks for your answer Gordan. Do you have more information about
3.0.2 ?
None, other than that Avati said a couple of days ago that it will be
available "very quickly".

Do you think the 3.0.1 could be a temporary solution or I have to wait ?
I don't think I could in good conscience recommend using a release labeled
by the developers as DOA, even if it seems better than a previous non-DOA

3.0.2rc1 is out and has been working fine in our tests thus far.
Please feel free to give it a try. It is very likely to become 3.0.2.

The virtual memory usage seems to be reasonably sane again, and resident memory usage actually seems to be a significant improvement on even 2.0.9.

BTW, I just found out that my gcc problem with gluster root was due to gcc (and cpp) having gotten corrupted along with a number of header files from glibc-headers and kernel-headers, in the usual file content swap clobbering way I described before. My best guess is that this happened when I ran yum update recently, as all of the mentioned packages got updated. Worryingly, this happened whan I was running 2.0.9, which indicates that there is a serious data corruption bug in it, and it's not even particularly related to open files (the chances of those particular header files all being open are pretty close to 0). What is the scope for a write getting mis-written to a wrong file due to an unexpected disconnect?

I think the evidence isn't just circumstantial any more - this corruption issue is happening with downright frightening regularity. I'd like to hope that 3.0.2rc1 solved this problem, but unless the cause is identified, and verified to not exist in the 3.0.x branch I think I'll have to limit my use of glusterfs to strictly non-live systems.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]