gnash-commit
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-commit] /srv/bzr/gnash/trunk r9614: More image abstraction, clean


From: Benjamin Wolsey
Subject: [Gnash-commit] /srv/bzr/gnash/trunk r9614: More image abstraction, cleanup, and removal of unused code.
Date: Mon, 18 Aug 2008 16:38:03 +0200
User-agent: Bazaar (1.5)

------------------------------------------------------------
revno: 9614
committer: Benjamin Wolsey <address@hidden>
branch nick: trunk
timestamp: Mon 2008-08-18 16:38:03 +0200
message:
  More image abstraction, cleanup, and removal of unused code.
modified:
  backend/render_handler.h
  backend/render_handler_agg.cpp
  backend/render_handler_cairo.cpp
  backend/render_handler_ogl.cpp
  backend/render_handler_ogl.h
  libbase/GnashImagePng.cpp
  libbase/image.cpp
  libbase/image.h
  libcore/asobj/NetStream.cpp
  libcore/asobj/NetStream.h
  libcore/asobj/NetStreamFfmpeg.cpp
  libcore/asobj/NetStreamFfmpeg.h
  libcore/asobj/NetStreamGst.cpp
  libcore/edit_text_character.cpp
  libcore/fill_style.cpp
  libcore/gnash.h
  libcore/impl.cpp
  libcore/movie_root.h
  libcore/parser/BitmapMovieDefinition.cpp
  libcore/parser/bitmap_character_def.cpp
  libcore/parser/bitmap_character_def.h
  libcore/render.cpp
  libcore/render.h
  libcore/swf/tag_loaders.cpp
  libmedia/VideoDecoder.h
  libmedia/ffmpeg/VideoDecoderFfmpeg.cpp
  libmedia/ffmpeg/VideoDecoderFfmpeg.h
  libmedia/gst/VideoDecoderGst.cpp
  libmedia/gst/VideoDecoderGst.h
    ------------------------------------------------------------
    revno: 9609.1.1
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 06:58:30 +0200
    message:
      Use LOG_ONCE.
    modified:
      libcore/edit_text_character.cpp
    ------------------------------------------------------------
    revno: 9609.1.2
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 06:58:52 +0200
    message:
      Silence g++4.3 warnings.
    modified:
      libbase/GnashImagePng.cpp
    ------------------------------------------------------------
    revno: 9609.1.3
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 06:59:09 +0200
    message:
      Gratuitous renaming of private members, put const qualifier on 
      scanlinePointer in the correct place.
    modified:
      libbase/image.cpp
      libbase/image.h
    ------------------------------------------------------------
    revno: 9609.1.4
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 07:14:18 +0200
    message:
      Use auto_ptr's reset() to delete.
    modified:
      backend/render_handler_ogl.cpp
    ------------------------------------------------------------
    revno: 9609.1.5
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 10:19:49 +0200
    message:
      Use algorithm in MovieLibrary.
    modified:
      libcore/impl.cpp
    ------------------------------------------------------------
    revno: 9609.1.6
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 10:37:50 +0200
    message:
      Rename image::rgb to image::ImageRGB and image::rgba to image::ImageRGBA
      for consistency and to prevent confusion with the rgba type (class) in
      types.h.
    modified:
      backend/render_handler.h
      backend/render_handler_agg.cpp
      backend/render_handler_cairo.cpp
      backend/render_handler_ogl.cpp
      backend/render_handler_ogl.h
      libbase/image.cpp
      libbase/image.h
      libcore/asobj/NetStreamFfmpeg.cpp
      libcore/asobj/NetStreamFfmpeg.h
      libcore/asobj/NetStreamGst.cpp
      libcore/fill_style.cpp
      libcore/parser/BitmapMovieDefinition.cpp
      libcore/parser/bitmap_character_def.cpp
      libcore/parser/bitmap_character_def.h
      libcore/render.cpp
      libcore/render.h
      libcore/swf/tag_loaders.cpp
      libmedia/VideoDecoder.h
      libmedia/ffmpeg/VideoDecoderFfmpeg.cpp
      libmedia/ffmpeg/VideoDecoderFfmpeg.h
      libmedia/gst/VideoDecoderGst.cpp
      libmedia/gst/VideoDecoderGst.h
    ------------------------------------------------------------
    revno: 9609.1.7
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 10:39:34 +0200
    message:
      image set_pixel -> setPixel
    modified:
      libcore/fill_style.cpp
    ------------------------------------------------------------
    revno: 9609.1.8
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 11:02:19 +0200
    message:
      Drop video type enums and videoFrameFormat because it was unimplemented
      on either side (renderer and image / NetStream) and because the enums
      were duplicated everywhere. If this needs to be implemented, it is easy
      to do it much better.
    modified:
      backend/render_handler.h
      backend/render_handler_agg.cpp
      backend/render_handler_cairo.cpp
      backend/render_handler_ogl.cpp
      libcore/asobj/NetStream.cpp
      libcore/asobj/NetStream.h
      libcore/render.cpp
      libcore/render.h
    ------------------------------------------------------------
    revno: 9609.1.9
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 11:17:45 +0200
    message:
      Drop delete_bitmap_info, which was unused and certainly shouldn't have
      been using free in render_handler_agg anyway. Not sure where bitmap_infos
      are deleted at all, but there's no need for a renderer function to do it.
    modified:
      backend/render_handler.h
      backend/render_handler_agg.cpp
      backend/render_handler_cairo.cpp
      backend/render_handler_ogl.cpp
      libcore/render.cpp
      libcore/render.h
    ------------------------------------------------------------
    revno: 9609.1.10
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 13:28:00 +0200
    message:
      Further abstract image handling, using ImageBase almost everywhere
      (except where setPixel is needed). Reduce duplicated code for RGB and
      RGBA images.
    modified:
      libbase/image.cpp
      libbase/image.h
      libcore/fill_style.cpp
      libcore/parser/BitmapMovieDefinition.cpp
      libcore/parser/bitmap_character_def.cpp
      libcore/parser/bitmap_character_def.h
      libcore/render.cpp
      libcore/render.h
      libcore/swf/tag_loaders.cpp
    ------------------------------------------------------------
    revno: 9609.1.11
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 13:39:35 +0200
    message:
      Clean up, use forward declarations.
    modified:
      libcore/render.cpp
      libcore/render.h
    ------------------------------------------------------------
    revno: 9609.1.12
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 15:31:00 +0200
    message:
      Move typedefs for movie_root callbacks to movie_root.
    modified:
      libcore/gnash.h
      libcore/movie_root.h
      libcore/render.h
    ------------------------------------------------------------
    revno: 9609.1.13
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Mon 2008-08-18 16:09:18 +0200
    message:
      Use the dynamic_cast in agg renderer handler rather than testing to see
      if it works and then static_casting. Use a dynamic_cast in other 
      renderers (drawVideoFrame).
    modified:
      backend/render_handler_agg.cpp
      backend/render_handler_cairo.cpp
      backend/render_handler_ogl.cpp
Diff too large for email (2099 lines, the limit is 1000).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]