[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-commit] /srv/bzr/gnash/trunk r9624: Fix build with older vers

From: Benjamin Wolsey
Subject: Re: [Gnash-commit] /srv/bzr/gnash/trunk r9624: Fix build with older versions of ffmpeg (which will abort if they encounter
Date: Sun, 24 Aug 2008 19:15:59 +0200

> gnash-head/libmedia/ffmpeg/VideoDecoderFfmpeg.cpp:257: error: 'CODEC_ID_VP6A' 
> was not declared in this scope
> Dunno since when it stopped working, but I'm sure it was working
> about one week ago..

I added it within the last week. I added a version check for
CODEC_ID_VP6A based on the version installed on my machine, which
obviously has it. So it seems you have the same or a later version of
ffmpeg which nevertheless doesn't have VP6A support.

In any case, the codec doesn't work with flash and it was a stop-gap
measure to prevent a segfault whenever Gnash encountered a codec it
couldn't handle. The fix involved (a) using the seemingly correct codec
for VP6A when it exists and (b) adding an assertion that fails when no
codec is found (before, Gnash tried to decode using CODEC_ID_UNKNOWN,
which is bad). So Gnash will still abort if any unsupported codec is
encountered. It needs more work.


Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil

reply via email to

[Prev in Thread] Current Thread [Next in Thread]