[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-dev] X11 dependency with FB gui

From: Rob Savoye
Subject: Re: [Gnash-dev] X11 dependency with FB gui
Date: Wed, 05 Dec 2007 07:58:45 -0700
User-agent: Thunderbird (X11/20071031)

strk wrote:
On Wed, Dec 05, 2007 at 03:41:57PM +0100, Udo Giacomozzi wrote:

See here for why X11 is checked even when build_fb is defined:
Briefly, you can do --enable-gui=fb,gtk ...
So we *do* want to check for X11.

No, we don't always want to look for X11, as neither the FB GUI or the new Qtopia support uses X11 at all. I'm also having this problem, but only when I used libmad/SDL for sound support.

That libs should link only if needed (but I guess you still need them
to build it if -l is specified...

  Correct. The X11 libraries are in the link line, this is the problem.

        - rob -

reply via email to

[Prev in Thread] Current Thread [Next in Thread]