[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re[2]: [Gnash-dev] Coordinate system discussion cont'd

From: Bastiaan Jacques
Subject: Re[2]: [Gnash-dev] Coordinate system discussion cont'd
Date: Wed, 7 May 2008 19:52:57 +0200 (CEST)

On Wed, 7 May 2008, Udo Giacomozzi wrote:
BJ> Actually, I think we should take the opportunity to resolve some
BJ> ambiguity with regards to the word "world". In the renderer, I believe
BJ> it's used to convert various coordinate systems (e.g. SWF def.) to renderer
BJ> coordinates and vice versa.

You mean AGG renderer, correct?
Right, there's a world_to_pixel and pixel_to_world.

These are part of the render_handler base class and all renderers must
implement them.

BJ> However, in libgeometry, I believe
BJ> world means something different namely, in a Range2d world means "contains
BJ> all possible points".

I'd say "extended to infinity in all directions".

I think setInfinite() is a lot more descriptive than setWorld(). So we
can eliminate confusion there.

BJ> So I'd definitely like to either clearly document the differences, or,
BJ> even better, use world to describe only a single thing.

I agree that we should remove (or rename) world_to_pixel and viceversa.

Okay, I propose we also rename Range2d::setWorld to Range2d::setFinite
(and related methods). That way, I think we'll have only one use for the
word "world", which is in the character class.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]