[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-dev] Plugin and codec error messages on YouTube

From: Jeremy C. Reed
Subject: Re: [Gnash-dev] Plugin and codec error messages on YouTube
Date: Fri, 3 Apr 2009 14:02:25 -0500 (CDT)

On Fri, 3 Apr 2009, Rob Savoye wrote:

> > Any hints on how to get gstreamer to use its audio/mpeg plugin?
>   Configure with --enable-media=ffmpeg :-) For good measure, install
> gstreamer-plugins-bad, and gstreamer-plugins-ugly to get everything you
> need.

Okay, I first tried again with gstreamer after installing 
gst-plugins0.10-bad-0.10.10nb2 Open source multimedia framework - bad plugins
gst-plugins0.10-ugly-0.10.10 Open source multimedia framework - ugly plugins

But no noticable change. (I don't know what tool to use to test my 
gstreamer other than totem but don't want to install it now with 
libgnomeui. I also see that the gst ffmpeg plugin used its own provided 

So I installed ffmpeg-20080727nb7 using pkgsrc (and lame with its unclear 
licensing). I used the ffplay (SDL frontend to ffmpeg) and it worked for 
me using:
$ youtube-dl ''
$ ffplay 9sJUDx7iEJw.flv
(I could watch and HEAR the video "but they can't help their neighbors" :)

Then I did a gmake distclean in my source and then:

 CXXFLAGS=-g CFLAGS=-g ./configure --enable-gui=gtk \
--prefix=/home/reed/gnash --with-npapi-plugindir=/home/reed/gnash/plugin \
--enable-media=ffmpeg 2>&1 | tee configure.log.6

 time gmake 2>&1 | tee make.log.6

which failed here:

libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I.. -I../libamf -I../libnet 
-I../libbase -I../libcore -pthread -I/usr/pkg/include 
-I/usr/pkg/include/glib/glib-2.0 -I/usr/pkg/lib/glib-2.0/include 
-I/usr/pkg/include -I/usr/pkg/include -I/usr/pkg/include 
-I/usr/pkg/include -I../libltdl -I/usr/pkg/include -I/usr/pkg/include 
-I/usr/pkg/include -g -pthread -pthread -W -Wall -Wcast-align -Wcast-qual 
-Wpointer-arith -Wreturn-type -Wnon-virtual-dtor -Wunused -MT 
libgnashmedia_la-MediaParserFfmpeg.lo -MD -MP -MF 
.deps/libgnashmedia_la-MediaParserFfmpeg.Tpo -c 
ffmpeg/MediaParserFfmpeg.cpp  -fPIC -DPIC -o 
/usr/pkg/include/libavcodec/avcodec.h:2353: warning: 'ImgReSampleContext' 
is deprecated (declared at /usr/pkg/include/libavcodec/avcodec.h:2347)
/usr/pkg/include/libavcodec/avcodec.h:2363: warning: 'ImgReSampleContext' 
is deprecated (declared at /usr/pkg/include/libavcodec/avcodec.h:2347)
ffmpeg/MediaParserFfmpeg.cpp: In member function 'void 
ffmpeg/MediaParserFfmpeg.cpp:428: warning: converting to '__uint64_t' from 
ffmpeg/MediaParserFfmpeg.cpp:460: warning: converting to '__uint64_t' from 
ffmpeg/MediaParserFfmpeg.cpp: In member function '__int64_t 
gnash::media::ffmpeg::MediaParserFfmpeg::seekMedia(__int64_t, int)':
ffmpeg/MediaParserFfmpeg.cpp:523: error: ISO C++ says that these are 
ambiguous, even though the worst conversion for the first is better than 
the worst conversion for the second:
/usr/include/g++/bits/postypes.h:175: note: candidate 1: 
std::fpos<_StateT> std::fpos<_StateT>::operator+(std::streamoff) const 
[with _StateT = __mbstate_t]
ffmpeg/MediaParserFfmpeg.cpp:523: note: candidate 2: 
operator+(std::streamoff, __int64_t) <built-in>
gmake[2]: *** [libgnashmedia_la-MediaParserFfmpeg.lo] Error 1
gmake[2]: Leaving directory `/home/reed/tmp/gnash-0.8.5/libmedia'
My g++ is from:

g++ (GCC) 4.1.3 20080704 prerelease (NetBSD nb2 20081120)

Logs from the build are at:

I am going to try to get this working from command-line before I pursue 
getting it to work in firefox.

Should I be using a newer ffmpeg version?

Should I use development code for gnash instead of 0.8.5 release?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]