[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-dev] Prepare patches

From: Benjamin Wolsey
Subject: Re: [Gnash-dev] Prepare patches
Date: Mon, 20 Apr 2009 09:40:50 +0200

> 1) must use gnash 0.8.5 trunk?

Patches against bzr trunk only, please.

> 2) i would change also the configure file and the makefile to add a new 
> gui based on our toolkit (reaction) and cairo instead the SDL one.

If there are no licensing conflicts with the GPLv3 it may be possible,
though maintenance would be your responsibility (or any other AmigaOS

I'm not really keen on adding more GUIs in the main repository. In fact,
I'd like to remove some, as they all have to be updated whenever the
interface changes (and there are already six fully-fledged GUIs plus the
dump gui), or they get out of date and leave Gnash's codebase in a mess.

You might also consider keeping it in a separate repository (which may
be a good idea for some existing but less-used GUIs) and maintaining it
there. If you want to do that (and again, if there are no licensing
problems), I should think we can provide links and info to that

What do other devs think?


Yes, YouTube does work in Gnash

Benjamin Wolsey, Software Developer -

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil

reply via email to

[Prev in Thread] Current Thread [Next in Thread]