[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-dev] problem compiling 0.8.5 and trunk

From: daniel
Subject: [Gnash-dev] problem compiling 0.8.5 and trunk
Date: Wed, 02 Sep 2009 16:58:48 +0200
User-agent: Webmail


I'm working with gnash in order to have it working under freescale powerpc platform. I have been able to compile and use version 0.8.3 against FB using AGG. Later I started playing with version 0.8.5 and trunk. My system is ubuntu 9.04 and gcc is 4.2.4.


 When trying to compile them I get the following errors:

- Version 0.8.5:

I have to manually set the SDL_CFLAGS in libbase/Makefile in order to compile, the system doesn't set this variable with the SDL header path. Later I in the compiling process I get this:


Making all in utilities
make[2]: Entering directory `/home/rbz/gnash/gnash-0.8.5/utilities'
g++ -DHAVE_CONFIG_H -I. -I..  -I../libbase -I../libnet -I../libamf -I../backend -I../libcore -I../libcore/asobj -I../libcore/parser -I../libcore/vm -I../libmedia -I../libsound -DLOCALEDIR=\"/usr/local/share/locale\" -pthread      -I../libmedia/gst   -g -O2 -pthread -pthread     -W     -Wall     -Wcast-align     -Wcast-qual     -Wpointer-arith     -Wreturn-type     -Wnon-virtual-dtor     -Wunused      -fvisibility-inlines-hidden -MT processor.o -MD -MP -MF .deps/processor.Tpo -c -o processor.o processor.cpp
processor.cpp: In function ‘int main(int, char**)’:
processor.cpp:354: error: ‘handler’ was not declared in this scope
make[2]: *** [processor.o] Error 1
make[2]: Leaving directory `/home/rbz/gnash/gnash-0.8.5/utilities'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rbz/gnash/gnash-0.8.5'
make: *** [all] Error 2

This problem is the same when crosscompiling and when compiling formy PC.

./configure --enable-gui=fb --enable-renderer=agg --enable-media=none --disable-shared --disable-menus --disable-plugins

- With trunk version the compilation stops when compiling files related to the microphone. The configure call is the same.

Is there any extra library I have to compile? are the options correct?


Thanks for all,


   Daniel Amor,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]