[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash] gnash testing

From: Jens Petersen
Subject: Re: [Gnash] gnash testing
Date: Sat, 08 Apr 2006 18:23:13 +0900
User-agent: Thunderbird 1.5 (X11/20060313)

Rob Savoye wrote:
Jens Petersen wrote:

I didn't manage to get a backtrace with gdb, perhaps it is crashing before there is a stack.

Are you running a debug build of Firefox, and then starting it with -g ".

No, I'm running /usr/bin/gnash. :)

With Gnash, you can also invoke the Flash movie and add "?waitforgdb=yes", and the plugin will block in the very being of it's initialization. Then you can attach GDB, and set breakpoints in that instance.

Sorry, where does one add that?

On FC4, I've had problems with ATK, of all things. GTK+ has been a bit of a moving target lately, so my gut feeling is this would be an issue with one of the dependent libraries.

Ok - FC5 moved to gtk 2.8 with cairo too, so....

The polling loop continues after playing to handle events. This will go away after the alpha release, cause I'm going to rewrite the event handling to be more portable and handle conditions it was never designed for.

Ok. :)

I haven't managed to get the plugin working properly in firefox.
Currently in FC4 it just seem to display the initial flash file background, but then nothing happens. (In FC5 the plugin crashes firefox as soon as it tries to render some flash.) I haven't tried i386.

   Hum, on my i386 FC4 laptop, it works just fine.

Ok, I'll try again on i386.

I'm not a fan of using pkg-config, as it doesn't exist on any non-GNU/Linux system, and many people don't even have this installed it turns out. So at one point I rewrote the configure tests for Gnash to do my own searching and not use pkg-config. So if you are having a configure problem, I'd prefer to fix my test, and no[t] add a dependency for pkg-config.

Ok, I quite like pkgconfig myself, but as long as configure works I'm not too fussy. ;-) Let me get back to you on where the current configure breaks for me.

I merged in a few of your spec file changes with the other patch I got for the spec file. I'll check this after I do a little RPM building testing.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]