[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash] Link Error on Ubuntu Dapper amd64

From: annonygmouse
Subject: Re: [Gnash] Link Error on Ubuntu Dapper amd64
Date: Wed, 10 May 2006 23:02:41 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; ca-AD; rv:1.7.12) Gecko/20060405 Debian/1.7.12-1.1

Rob Savoye wrote:
Jay Miller wrote:


Same problem here.

g++ -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I. -I.. -I../server -I/usr/include -I/usr/include/libxml2 -I/usr/include/SDL -I/usr/include/SDL -DQT_THREAD_SUPPORT -D_REENTRANT -I.. -I. -I.. -I../server -I/usr/include -I/usr/include/libxml2 -I/usr/include/SDL -I/usr/include/SDL -g -O2 -ansi -Wall -fvisibility-inlines-hidden -MT zlib_adapter.lo -MD -MP -MF .deps/zlib_adapter.Tpo -c zlib_adapter.cpp -o zlib_adapter.o >/dev/null 2>&1 /bin/sh ../libtool --tag=CXX --mode=link g++ -I.. -I. -I.. -I../server -I/usr/include -I/usr/include/libxml2 -I/usr/include/SDL -I/usr/include/SDL -g -O2 -ansi -Wall -fvisibility-inlines-hidden -o -rpath /usr/local/lib config.lo container.lo image.lo image_filters.lo jpeg.lo log.lo membuf.lo ogl.lo postscript.lo triangulate_float.lo triangulate_sint32.lo tu_file.lo tu_file_SDL.lo tu_random.lo tu_timer.lo tu_types.lo utf8.lo utility.lo zlib_adapter.lo -lSDL_mixer -lrt g++ -shared -nostdlib /usr/lib/gcc/x86_64-linux-gnu/4.0.4/../../../../lib64/crti.o /usr/lib/gcc/x86_64-linux-gnu/4.0.4/crtbeginS.o .libs/config.o .libs/container.o .libs/image.o .libs/image_filters.o .libs/jpeg.o .libs/log.o .libs/membuf.o .libs/ogl.o .libs/postscript.o .libs/triangulate_float.o .libs/triangulate_sint32.o .libs/tu_file.o .libs/tu_file_SDL.o .libs/tu_random.o .libs/tu_timer.o .libs/tu_types.o .libs/utf8.o .libs/utility.o .libs/zlib_adapter.o /usr/lib/ -lrt -L/usr/lib/gcc/x86_64-linux-gnu/4.0.4 -L/usr/lib/gcc/x86_64-linux-gnu/4.0.4/../../../../lib64 -L/usr/lib/gcc/x86_64-linux-gnu/4.0.4/../../.. -L/lib/../lib64 -L/usr/lib/../lib64 -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-linux-gnu/4.0.4/crtendS.o /usr/lib/gcc/x86_64-linux-gnu/4.0.4/../../../../lib64/crtn.o -Wl,-soname -Wl, -o .libs/ /usr/bin/ld: .libs/log.o: relocation R_X86_64_PC32 against `std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string()@@GLIBCXX_3.4' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
make[2]: *** [] Error 1
make[2]: Leaving directory `/home/jo/gnash/libbase'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jo/gnash'
make: *** [all] Error 2

As I'm still not proficient with CVS i erased gnash and cheked it out again and I still get this error (I get it since yesterday).

My machine is a Debian pure64 (amd64) on unstable and has not been updated since a week or so.

Kind regards

___________________________________________________________ To help you stay safe and secure online, we've developed the all new Yahoo! Security Centre.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]