[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash] gnash not linking to the right libGL when --enable-plugin is sel

From: Gian Paolo Mureddu
Subject: [Gnash] gnash not linking to the right libGL when --enable-plugin is selected.
Date: Fri, 14 Jul 2006 12:15:25 -0500

Hi list,

I still have the problem of gnash not linking to the right libGL when I build the program with --enable-plugin. I have an x86_64 Fedora Core 5 system, with the nVidia drivers installed, and the GL headers also installed. I however, have also installed the compat 32-bit libGL libraries.

For some reason, and for a long time now, Gnash will try to link to /usr/lib/, i.e the 32-bit library, however I'm building for 64-bit, and hece I need gnash to link against /usr/lib64/ I have tried (or at least I think I have) everything to make gnash link to the right libGL, but I am still unsuccessful.

Any one with a mixed environment of 32-bit and 64-bit libraries have actually had any success building the plugin? I've pretty much ran out of ideas, and I would really appreaciate to run gnash as a plugin and not only as a standalone player (which is really awesome, actually). I have tried to set the GLEXT_LIBS and OPENGL_LIBS and OPENGL_CFLAGS variables to the right location in the configure script and Makefiles, and still am unable to make gnash link against the right libGL, what should I attempt?


PS: Anyone with a Fedora Core 5 x86_64 system with the nVidia drivers installed and the compat 32-bit libraries also installed? Help would be much appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]