[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash] Licensing issues with Gnash KDE GUI

From: Aidan Thornton
Subject: [Gnash] Licensing issues with Gnash KDE GUI
Date: Wed, 12 Dec 2007 09:48:09 +0000


There appears to be a nasty licensing issue with the Gnash KDE GUI.
Gnash (and its KDE GUI code) are now licensed under the GPL3. However,
it has to be linked against QT, which is as far as I can tell still
GPL2-only. At the very least, this makes the resulting binaries
unredistributable, and I'm not sure about the legality of
redistribution in source form. (I think the FSF did make legal threats
against AFPL Ghostscript for distributing optional code under a
GPL2-incompatible license that was intended to be linked against a
GPL2 library, but I don't know how valid this is legally). At the very
least, users should be warned about the potential legal issues they're
likely to encounter, especially as AFAIK building the KDE GUI is still
the default.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]