[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnewsense-dev] debian on yeeloong SOLVED :)

From: Elly Liu
Subject: Re: [Gnewsense-dev] debian on yeeloong SOLVED :)
Date: Wed, 21 Jan 2009 10:07:12 +0800


All after this, do you have trouble using the wired connection and wireless? I can't connect to wired or wifi. String Tang who's working with me, tested another wired connection just now, the connection can receive but can't send, nothing wrong with the connection itself.



On Wed, Jan 21, 2009 at 1:33 AM, Graziano Sorbaioli <address@hidden> wrote:
Hash: SHA1

Finally, thanks to a HUGE help from "D--", a #beijinglug hero,  I
managed to install Debian into the Lemote Yeeloong.

Here is D--'s website:

Feel free to say thanks. :)

Here are the instructions:

0. Download the debian loongson image:

1. Use gparted to format a partition on a USB disk to ext3.

2. Mount it, change to the folder inside the usb /, and run `tar xjpvf

3. Open /media/YOUR_NEW_EXT3/etc/fstab and comment out all lines except

4. Run `sync`. Be patient. Remove your USB disk.

5. Start the Yeelong. Open terminal. Remount / as rw instead of ro this way:

mount -o remount, rw /

6. Edit /boot/boot.cfg. Make sure it has "showmenu 1". Add these lines.

title Debian on Yeeloong
kernel /dev/fs/address@hidden/boot/vmlinux-yeeloong
args console=tty root=/dev/sda1 no_auto_cmd rootdelay=10

7. Power down. Plug in your USB key.

8. Press DEL.
At the pmon prompt write:

load /dev/fs/address@hidden/boot/vmlinux-yeeloong
g console=tty root=/dev/sda1 no_auto_cmd rootdelay=10

Then the system will boot into your new shining debian. :)

D-- suggested:

If you get a kernel panic about not being able to mount root (/), check
if it is mapping it as sda. The supplied kernel has a quirk where it
mounts and unmounts the device creating it as sdb the second time. My
new kernel for medan doesn't have this problem.

If you continue to have trouble, I suggest trying a USB hard disk, not a
USB stick. I've had a lot of bad experiences with sticks flaking out and
writing 0s inside of files. A USB hard disk will not have this problem.


- --
Graziano Sorbaioli --
Join the Free Software Foundation:
Supporters will receive our new USB membership card with gNewSense Live

Version: GnuPG v1.4.9 (GNU/Linux)


gNewSense-dev mailing list

CONFIDENTIALITY NOTICE: This message and any attached documents may contain confidential information which is intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, or an employee or agent responsible for the delivery of this message to the intended recipient, the reader is hereby notified that any dissemination, distribution or copying of this message or of any attached documents, or the taking of any action or omission to take any action in reliance on the contents of this message or of any attached documents, is strictly prohibited. If you have received this communication in error, please notify the sender immediately by e-mail, and delete the original message immediately. Thank you!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]