[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnewsense-dev] gNewSense update: app-install-data-commercial

From: Sam Geeraerts
Subject: Re: [Gnewsense-dev] gNewSense update: app-install-data-commercial
Date: Sun, 02 Aug 2009 11:08:39 +0200
User-agent: Thunderbird (X11/20090711)

Karl Goetz schreef:
On Sat, 01 Aug 2009 19:25:09 +0200
Sam Geeraerts <address@hidden> wrote:

Karl Goetz schreef:
I noticed that too, so I've reopened the bug report:
Its a regression, so its now highest priority.
Wonder what I've done ....

Thanks for the bugreport and investigations. I'll look at it when I
can (next few days).
Looks like it was a broken archive push. Should be ok now (Bug is
closed in any case).

I have just taken the time to install long overdue updates on my
laptop and I noticed that app-install-data-commercial was in the list
of updates there also. So I tried reinstalling it on my desktop
machine and that worked, albeit with a lot messages about desktop
files. Example for completeness:

Do you still have gnewsense-desktop installed?


entry: kttsmgr.desktop
Toegankelijkheid/ kttsmgr.desktop /usr/share/app-install/desktop/kttsmgr.desktop
we have a application kttsmgr (kttsmgr.desktop)
parent is Toegankelijkheid

What package generates these
errors? /usr/share/app-install/desktop/kttsmgr.desktop is unknown to in hardy[-security],-updates or -backports.

It turns out they're not errors. In the attached file you can see that it's a configuration step when installing the package. (Nevermind the error at the end, that's caused by my attempts to figure out bug 309.)

I checked for kttsmgr.desktop myself and it really is in Hardy [1].

I removed it again and then disabled deltah-updates. I tried to
install it again, but now apt-get says:

Package app-install-data-commercial is not available, but is referred
to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package app-install-data-commercial has no installation candidate

Could you run `apt-cache policy app-install-data-commercial`. and
`apt-cache rdepends app-install-data-commercial`

With deltah-updates enabled:

  Installed: (none)
  Candidate: 9.5
  Version table:
     9.5 0
        500 deltah-updates/main Packages

Reverse Depends:

With deltah-updates disabled:

  Installed: (none)
  Candidate: (none)
  Version table:


I saw that you changed the remove_package code in Builder. I don't
know if that somehow reintroduced this bug or that your earlier
solution for it didn't have the effect you'd hoped.

Probably the latter. If we manage to connect on IRC I'll try and work
through it with you. I have a reasonably clean install for testing
which isn't displaying symptoms anything like yours.
Perhaps we need to get some more opinions/input to isolate the

Regardless of whether you're seeing these symptoms, there are files in our repo that shouldn't be in there. We have an app-install-data-commercial directory [2] with the version from deltah-updates (9.5), but not the version from deltah (9).

[1] [2]
Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Building tag database...
The following packages have been automatically kept back:
  bind9-host gvfs gvfs-backends libbind9-30 libdns35 libgvfscommon0 
  libisc35 libisccc30 libisccfg30 liblwres30 libnautilus-extension1 
  libpulse-browse0 libpulse0 libpulsecore5 libruby1.8 libsmbclient 
  linux-libc-dev nautilus-data pulseaudio-utils python2.5 python2.5-dev 
  samba-common xulrunner-1.9 
The following packages have been kept back:
  dnsutils gvfs-fuse icecat linux-headers-2.6.24-24 
  linux-headers-2.6.24-24-generic linux-image-2.6.24-24-386 nautilus 
  pulseaudio pulseaudio-esound-compat pulseaudio-module-gconf 
  pulseaudio-module-hal pulseaudio-module-x11 python2.5-minimal smbclient 
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 0 to remove and 38 not upgraded.
Need to get 0B/54.3kB of archives. After unpacking 172kB will be used.
Writing extended state information...
Selecting previously deselected package app-install-data-commercial.
(Reading database ... 229269 files and directories currently installed.)
Unpacking app-install-data-commercial (from 
.../app-install-data-commercial_9.5_all.deb) ...
Setting up app-install-data-commercial (9.5) ...
Caching application data...
entry: Accessories
we have a sub-menu Accessories 
entry: 7zip.desktop
Accessories/    7zip.desktop    /usr/share/app-install/desktop/7zip.desktop
we have a application 7zip (7zip.desktop) 
parent is Accessories
entry: ace.desktop
Accessories/    ace.desktop     /usr/share/app-install/desktop/ace.desktop
we have a application ACE (ace.desktop) 
parent is Accessories
entry: AClock.desktop
Accessories/    AClock.desktop  /usr/share/app-install/desktop/AClock.desktop
we have a application AClock (AClock.desktop) 
parent is Accessories
entry: albumshaper.desktop
Accessories/    albumshaper.desktop     
we have a application Album Shaper (albumshaper.desktop) 
parent is Accessories
entry: kde4.desktop
Other/  kde4.desktop    /usr/share/app-install/desktop/kde4.desktop
we have a application KDE4 (kde4.desktop) 
parent is Other
entry: kseg.desktop
Other/  kseg.desktop    /usr/share/app-install/desktop/kseg.desktop
we have a application KSeg Geometry Sketchpad (kseg.desktop) 
parent is Other
entry: kipina.desktop
Other/  kipina.desktop  /usr/share/app-install/desktop/kipina.desktop
Traceback (most recent call last):
  File "/usr/sbin/update-app-install", line 6, in <module>
  File "/usr/lib/python2.5/site-packages/AppInstall/", line 104, in 
    generate_menu_cache(options.desktop_dir, options.cache_dir)
  File "/usr/lib/python2.5/site-packages/AppInstall/", line 70, in 
  File "/usr/lib/python2.5/site-packages/AppInstall/", line 40, in 
  File "/usr/lib/python2.5/site-packages/AppInstall/", line 54, in 
    self._populateFromEntry(entry, item,  progress=progress)
  File "/usr/lib/python2.5/site-packages/AppInstall/", line 61, in 
    self._dbg(1, "we have a application %s (%s) " % (name,entry.DesktopFileID))
  File "/usr/lib/python2.5/site-packages/AppInstall/", line 151, in 
    print >> sys.stderr, msg
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe4' in position 
27: ordinal not in range(128)

Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Writing extended state information...
Building tag database...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]