[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnewsense-dev] software-properties-gtk error

From: Sam Geeraerts
Subject: Re: [Gnewsense-dev] software-properties-gtk error
Date: Mon, 25 Jan 2010 23:51:23 +0100
User-agent: Thunderbird (X11/20090824)

Quiliro Ordóñez schreef:
When I try to change the contents of /etc/apt/sources.list via
Syunaptics interface I get a window with the following message (I
translated it):

The repositories have changed.

The information from the repositories has changed. You should press
the "Reload" button so these changes come into effect.

But I never get the window where I am supposed to chage the repos.
Tryed erasing /etc/apt/sources.list and removing all entries except
one. But no luck.

Executing from the console I get:

$ sudo /usr/bin/software-properties-gtk
/usr/lib/python2.5/site-packages/apt/ FutureWarning:
apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 100, in <module>
    app = SoftwarePropertiesGtk(datadir=data_dir, options=options, file=file)
line 75, in __init__
    SoftwareProperties.__init__(self, options=options, datadir=datadir)
line 55, in __init__
line 450, in reload_sourceslist
  File "/usr/lib/python2.5/site-packages/aptsources/", line
85, in get_sources
    "Error: could not find a distribution template")

Looks like a directory (link?) was removed from the repo. File in package python-apt needs to be fixed.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]