[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnewsense-dev] installable on mipsel again

From: Imad-Eddine SRAIRI
Subject: Re: [Gnewsense-dev] installable on mipsel again
Date: Mon, 26 Apr 2010 14:13:17 +0200


I had the same problem as Graziano: no reboot after installation - the
system hung with the GNU+Freedo logo displayed at the top of an entirely
empty, black screen.

At this stage, I was aware that I had ignored several warnings of the
installer urging me to define/configure a boot loader, but I did not
know what to fill in (and where). I had not used all information found

either, in particular things related to grub.

So I restarted the computer and pressed del again, to get back to pmon.

The commands listed in paragraph 5 of first section worked:
dir (wd0,0)/boot
and showed that files


did exist in (wd0,0)/boot, so I typed commands listed in paragraph 6:
load (wd0,0)/boot/vmlinux-
initrd (wd0,0)/boot/initrd.img-
g console=tty no_auto_cmd root=/dev/hda1 rootdelay=8
replacing 31.6-libre1 by 32.9-libre-lemote.

Actually I inserted this one before the third line:
set al (wd0,0)/boot/vmlinux-
which is also mentioned on the wiki.

The system restarted, went beyond the hanging point previously
encountered, and started to check the disk. Errors were detected and
corrected, so it spontaneously rebooted again. I thought I was done with
it and let it go on without interfering, but it hung again. One more
'off+on+del' later, I was back in pmon and retyped the three lines
quoted above. The system started and I was able to log in. I checked
content of /boot/boot.cfg and /etc/default/grub and edited the latter
like this:

GRUB_CMDLINE_LINUX="console=tty no_auto_cmd machtype=8.9"

(I do not like the 'quiet' option, so I left GRUB_CMDLINE_LINUX_DEFAULT
unchanged to "".)

I ran 'update-grub2' (as root) (notice the '2' because this is what I
found in /boot/boot.cfg: grub version 2) and restarted: everything seems
to work now.

Graziano, if you manage to confirm that the same steps work for you
(there is nothing new here really wrt the wiki's current content, except
maybe a few additional details), we could add these details on the wiki
page to help future generations of metad-installer-wannabes like
me... :-)



On Mon, 2010-04-26 at 19:26 +0930, Karl Goetz wrote:
> On Sun, 25 Apr 2010 12:03:15 +0200
> Graziano Sorbaioli <address@hidden> wrote:
> (no need for a cc, i read the list ;))
> > Karl Goetz ha scritto:
> > > hi all,
> > > Sorry about the delay, but we should be able to install gNS on
> > > yeeloong again.
> > > 
> > > If you have an error where you are unable to get a release file from
> > > the mirror, reply back to this thread and let us know.
> > > kk
> > 
> > 
> > It hangs for me after installation has completed.
> :(
> Not that I was saying it would work, just install ;)
> > When I reboot it shows grub then loads the first kernel (I installed 
> > using, it shows the GNU/Linux-libre 100%freedom logo and
> > hangs there.
> I've not tried with that kernel, so i cant comment on if it'll work.
> We do have a lot of different kernels, all of which work in different
> ways. would be nice to sort that mess out sometime.
> kk
> _______________________________________________
> gNewSense-dev mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]