gnewsense-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnewsense-dev] Builder: vlc build failed


From: Dmitry Samoyloff
Subject: Re: [Gnewsense-dev] Builder: vlc build failed
Date: Thu, 10 Jun 2010 02:08:13 +0400
User-agent: Wanderlust/2.14.0 (Africa) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.7 Emacs/22.1 (i486-pc-linux-gnu) MULE/5.0 (SAKAKI)

At Wed, 09 Jun 2010 22:43:54 +0200,
Sam Geeraerts wrote:
> 
> Dmitry Samoyloff schreef:
> > I see the following code in gen-vlc:
> > 
> >   # Edit debian/control to depend on the (older) automake required.
> >   # This has to happen before fetching build-deps, so its now done here
> >   sed -i -e  's/automake/automake1.9/' debian/control
> >   apt-get --yes build-dep vlc$VERSION
> > 
> > However, the last line does nothing. Here's the output of do-update:
> > 
> >   <...>
> >   + sed -i -e s/automake/automake1.9/ debian/control
> >   + apt-get --yes build-dep 
> > vlc=0.8.6.release.e+x264svn20071224+faad2.6.1-0ubuntu3
> >   Reading package lists... Done
> >   Building dependency tree       
> >   Reading state information... Done
> >   0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> >   <...>
> > 
> > automake1.9 is not installed in chroot at the moment! This looks like a bug.
> > A first thought: should the "sed ..." line affect "apt-get build-dep" at 
> > all?
> > IIUC apt-get gets info from the cache and my
> > /var/lib/apt/lists/127.0.0.1_ubuntu_dists_hardy_universe_source_Sources 
> > still
> > contains "automake" in vlc's Build-Depends section, not "automake1.9".
> 
> Good point. I remember that there was an issue involving automake when 
> we tried to build vlc and I was not the one that solved it. It seems 
> that the script needs an extra 'apt-get automake1.9'. I'll have a look 
> at that tomorrow.

Here's a good fix, I suppose:



=== modified file 'gen-vlc'
--- gen-vlc     2010-02-18 01:51:26 +0000
+++ gen-vlc     2010-06-09 21:32:26 +0000
@@ -31,9 +31,11 @@
 rm modules/stream_out/transrate/putvlc.h
 
 # Edit debian/control to depend on the (older) automake required.
-# This has to happen before fetching build-deps, so its now done here
 sed -i -e  's/automake/automake1.9/' debian/control
+
+# Install build dependencies.
 apt-get --yes build-dep vlc$VERSION
+apt-get install automake1.9
 
 echo | dch -D $RELEASE -v $(sed  -n 
'1s#^.*(\(.*\)).*#\1'${DISTRONAME_L}${VLC_VERSION}'#p' debian/changelog)  
"Changed to remove non-free file"



I think, apt-get just have no opportunity to realize a newly added dependency,
so we should install it explicitly.

> Every time someone tries Builder we get to squash a bug. I like it. :)

:-)

--
I'm an FSF member -- Help us support software freedom!
<http://www.fsf.org/jf?referrer=7253>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]